summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-10-19 02:29:00 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-22 22:17:28 -0400
commit799075605338f9c8f0e3eb52257aceb4099a203e (patch)
tree86d7161ad685b28fba66d74e44125c3ef36b6cfd /gnu/packages
parent28a9e296f8fad8ee4ddc93987d80fb484c6c79fa (diff)
gnu: go-github-com-golangplus-testing: Move to (gnu packages golang-check).
* gnu/packages/golang.scm (go-github-com-golangplus-testing): Move from here... * gnu/packages/golang-check.scm: ... to here. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-check.scm24
-rw-r--r--gnu/packages/golang.scm22
2 files changed, 24 insertions, 22 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 8c6bf03f74..414423a5ef 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
;;; Copyright © 2019 Leo Famulari <leo@famulari.name>
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
+;;; Copyright © 2020 Joseph LaFreniere <joseph@lafreniere.xyz>
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
;;; Copyright © 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2023 Felix Lechner <felix.lechner@lease-up.com>
@@ -38,6 +39,29 @@
;;;
;;; Code:
+(define-public go-github-com-golangplus-testing
+ (package
+ (name "go-github-com-golangplus-testing")
+ (version "1.0.0")
+ (home-page "https://github.com/golangplus/testing")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1a29m4zplf9m14k74lrb55dids2l17vx28sv0g3y3qcv1xygksiv"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/golangplus/testing"))
+ (propagated-inputs
+ (list go-github-com-golangplus-fmt))
+ (synopsis "Additions to Go's standard testing package")
+ (description "This package provides additions to Go's stdlib testing.")
+ (license license:bsd-3)))
+
(define-public go-github-com-jacobsa-oglematchers
(let ((commit "141901ea67cd4769c6800aa7bfdfc558fa22bda5")
(revision "0"))
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index afc1a9bd30..cfd7fb73ad 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3006,28 +3006,6 @@ Under Windows, the console APIs are used. Otherwise, ANSI texts are output.")
;; dual-licensed
(license (list license:bsd-3 license:expat))))
-(define-public go-github-com-golangplus-testing
- (package
- (name "go-github-com-golangplus-testing")
- (version "1.0.0")
- (home-page "https://github.com/golangplus/testing")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url home-page)
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1a29m4zplf9m14k74lrb55dids2l17vx28sv0g3y3qcv1xygksiv"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/golangplus/testing"))
- (propagated-inputs
- (list go-github-com-golangplus-fmt))
- (synopsis "Additions to Go's standard testing package")
- (description "This package provides additions to Go's stdlib testing.")
- (license license:bsd-3)))
-
(define-public go-github-com-leodido-go-urn
(package
(name "go-github-com-leodido-go-urn")