summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-11-18 10:34:21 +0100
committerMarius Bakke <marius@gnu.org>2022-11-20 07:47:16 +0100
commit915360ee9c4a8f948737267184918996fa271aa5 (patch)
treeaf19a35f1b69b6f4f7e4e491a62999bc5a43da11 /gnu/packages
parent79cfd21411400915952a48b3e18a678c5df64412 (diff)
gnu: libx264: Update to 164-0.b093bbe.
* gnu/packages/video.scm (libx264): Update to 164-0.b093bbe. (libx264-next): Remove variable. * gnu/packages/jami.scm (ffmpeg-jami)[inputs]: Don't use LIBX264-NEXT.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/jami.scm3
-rw-r--r--gnu/packages/video.scm27
2 files changed, 4 insertions, 26 deletions
diff --git a/gnu/packages/jami.scm b/gnu/packages/jami.scm
index a9a988ca5a..2c5a4c8d88 100644
--- a/gnu/packages/jami.scm
+++ b/gnu/packages/jami.scm
@@ -424,8 +424,7 @@
"mov ismv")
(("fate-lavf-mov_rtphint:.*") ""))))))))
(inputs (modify-inputs (package-inputs ffmpeg-5)
- (replace "libvpx" libvpx-next)
- (replace "libx264" libx264-next)))))
+ (replace "libvpx" libvpx-next)))))
(define-public libjami
(package
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 7f2112de0d..f30f567206 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -912,8 +912,8 @@ shared library and encoder and decoder command-line executables.")
(define-public libx264
;; There are no tags in the repository, so we take the version number from
;; the X264_BUILD variable defined in x264.h.
- (let ((version "161")
- (commit "4c2aafd864dd201832ec2be0fef4484925146650")
+ (let ((version "164")
+ (commit "b093bbe7d9bc642c8f24067cbdcc73bb43562eab")
(revision "0"))
(package
(name "libx264")
@@ -926,7 +926,7 @@ shared library and encoder and decoder command-line executables.")
(file-name (git-file-name name version))
(sha256
(base32
- "1i6v9h3xx9pi0zmlj3anwwjxqa63sbhy9crrif8dphipwfn9hyg5"))))
+ "095pv8y6fqjg8mdvsfk12d0jqgyhip536a6vxhzm7qz8hfp96qhq"))))
(build-system gnu-build-system)
(native-inputs
(list pkg-config nasm))
@@ -976,27 +976,6 @@ H.264 (MPEG-4 AVC) video streams.")
"file://extras/cl.h"
"See extras/cl.h in the distribution."))))))
-;;; TODO: Merge into libx264 on staging.
-(define-public libx264-next
- ;; There are no tags in the repository, so we take the version number from
- ;; the X264_BUILD variable defined in x264.h.
- (let ((version "164")
- (commit "b093bbe7d9bc642c8f24067cbdcc73bb43562eab")
- (revision "0"))
- (package
- (inherit libx264)
- (name "libx264")
- (version (git-version version revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://code.videolan.org/videolan/x264.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "095pv8y6fqjg8mdvsfk12d0jqgyhip536a6vxhzm7qz8hfp96qhq")))))))
-
(define-public mkvtoolnix
(package
(name "mkvtoolnix")