summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-14 21:53:07 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:07 +0200
commitf626769b3aaa9c3ba9c5b0b56f68b0591ce574b8 (patch)
tree86b7eaed5f459735dba8c538a96a01e68746d4be /gnu/packages
parentac29f53d304ed6b875562375fbc66c9cd366f8fd (diff)
gnu: texlive-tex-plain -> texlive-plain.
* gnu/packages/tex.scm (texlive-plain): New variable. (texlive-tex-plain): Deprecate variable. (texlive-hyph-utf8): (texlive-latex-base): (texlive-pdftex): (texlive-xetex): * gnu/packages/chez.scm (chez-web): Use new name.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/chez.scm2
-rw-r--r--gnu/packages/tex.scm42
2 files changed, 27 insertions, 17 deletions
diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index b988b00fd7..86dd47d2ec 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -1025,7 +1025,7 @@ create compilers, making them easier to understand and maintain.")
texlive-pdftex
texlive-context
texlive-cm
- texlive-tex-plain))))
+ texlive-plain))))
(arguments
(list
#:make-flags
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a83310619e..643030870d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1723,15 +1723,23 @@ programmers may assume e-TeX functionality. The pdftex engine directly
incorporates the e-TeX extensions.")
(license license:knuth))))
-(define-public texlive-tex-plain
+(define-public texlive-plain
(package
- (inherit (simple-texlive-package
- "texlive-tex-plain"
- (list "/tex/plain/")
- (base32
- "1hafbphx1486069cky87hyksx6ia5gd83m4wp2xmgc09z87faf0h")
- #:trivial? #t))
- (home-page "https://www.ctan.org/pkg/plain")
+ (name "texlive-plain")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "makeindex/plain/" "tex/plain/base/"
+ "tex/plain/config/")
+ (base32
+ "0zwvrfw8z28c9dy8nby5qfwbyrd2a0cdfwyd5jndscjczhw0yi62")))
+ (build-system texlive-build-system)
+ (arguments
+ (list
+ #:tex-engine "tex"
+ #:tex-format #f
+ #:texlive-latex-base #f))
+ (home-page "https://ctan.org/pkg/plain")
(synopsis "Plain TeX format and supporting files")
(description
"This package contains files used to build the Plain TeX format, as
@@ -1739,6 +1747,8 @@ described in the TeXbook, together with various supporting files (some also
discussed in the book).")
(license license:knuth)))
+(define-deprecated-package texlive-tex-plain texlive-plain)
+
(define-public texlive-halloweenmath
(let ((template (simple-texlive-package
"texlive-halloweenmath"
@@ -2724,7 +2734,7 @@ T1/EC and UTF-8 encodings.")
(mkdir-p where)
(with-directory-excursion where
(invoke "tex" "-ini"
- (string-append (assoc-ref inputs "texlive-tex-plain")
+ (string-append (assoc-ref inputs "texlive-plain")
"/share/texmf-dist/tex/plain/config/tex.ini"))))))
(add-before 'build 'build-loaders-and-converters
(lambda* (#:key outputs #:allow-other-keys)
@@ -2759,12 +2769,12 @@ T1/EC and UTF-8 encodings.")
(native-inputs
(list ruby-2.7
texlive-bin
- ;; The following packages are needed for build "tex.fmt", which we need
- ;; for a working "tex".
- texlive-tex-plain
+ ;; The following packages are needed for build "tex.fmt", which we
+ ;; need for a working "tex".
texlive-cm
texlive-knuth-lib
- texlive-hyphen-base))
+ texlive-hyphen-base
+ texlive-plain))
(home-page "https://ctan.org/pkg/hyph-utf8")
(synopsis "Hyphenation patterns expressed in UTF-8")
(description "Modern native UTF-8 engines such as XeTeX and LuaTeX need
@@ -3152,7 +3162,7 @@ formats.")
(native-inputs
`(("texlive-bin" ,texlive-bin)
("texlive-tex-ini-files" ,texlive-tex-ini-files)
- ("texlive-tex-plain" ,texlive-tex-plain)
+ ("texlive-plain" ,texlive-plain)
("texlive-kpathsea" ,texlive-kpathsea)
("texlive-cm" ,texlive-cm)
("texlive-latex-fonts" ,texlive-latex-fonts)
@@ -8489,7 +8499,7 @@ e-TeX.")
texlive-hyphen-base
texlive-kpathsea
texlive-tex-ini-files
- texlive-tex-plain))
+ texlive-plain))
(home-page "https://www.ctan.org/pkg/pdftex")
(synopsis "TeX extension for direct creation of PDF")
(description
@@ -12929,7 +12939,7 @@ itself may be shipped out to the DVI file.")
texlive-l3packages
texlive-lm
texlive-tex-ini-files
- texlive-tex-plain
+ texlive-plain
texlive-unicode-data))
(home-page "https://www.tug.org/texlive/")
(synopsis "Extended variant of TeX for use with Unicode sources")