summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-11-03 08:07:32 -0400
committerLeo Famulari <leo@famulari.name>2017-11-04 10:32:30 -0400
commitf9c3bd2e0183b777ad3794674a360222c62633b0 (patch)
treed06789f2ef227b11d9144486569d159a4f95c6e9 /gnu/packages
parent232ffa842d0c14bccf16ae5aa26537148ad021bd (diff)
gnu: Generalize the variable name of the test-only tzdata package.
* gnu/packages/base.scm (tzdata-2017a): Rename variable to tzdata-for-tests. * gnu/packages/calcurse.scm (calcurse)[native-inputs, arguments]: Adjust accordingly. gnu/packages/glib.scm (glib): Likewise. * gnu/packages/perl.scm (perl-libtime-parsedate): Adjust accordingly and add tzdata-for-tests #:disallowed-references. * gnu/packages/statistics.scm (r-minimal): Adjust accordingly.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/base.scm2
-rw-r--r--gnu/packages/calcurse.scm4
-rw-r--r--gnu/packages/glib.scm4
-rw-r--r--gnu/packages/perl.scm5
-rw-r--r--gnu/packages/statistics.scm4
5 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index b2a01c68dc..109e9b698d 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -1125,7 +1125,7 @@ and daylight-saving rules.")
;;; A "fixed" version of tzdata, which is used in the test suites of
;;; glib and R. We can update this whenever we are able to rebuild
;;; thousands of packages (for example, in a core-updates rebuild).
-(define-public tzdata-2017a
+(define-public tzdata-for-tests
(package
(inherit tzdata)
(version "2017a")
diff --git a/gnu/packages/calcurse.scm b/gnu/packages/calcurse.scm
index 44e90448cd..93eeaf0ee6 100644
--- a/gnu/packages/calcurse.scm
+++ b/gnu/packages/calcurse.scm
@@ -40,7 +40,7 @@
"0il0y06akdqgy0f9p40m4x6arn66nh7sr1w1i41bszycs7div266"))))
(build-system gnu-build-system)
(inputs `(("ncurses" ,ncurses)))
- (native-inputs `(("tzdata" ,tzdata-2017a)))
+ (native-inputs `(("tzdata" ,tzdata-for-tests)))
(arguments
;; The ical tests all want to create a ".calcurse" directory, and may
;; fail with "cannot create directory '.calcurse': File exists" if run
@@ -49,7 +49,7 @@
;; Since this tzdata is only used for tests and not referenced by the
;; built package, used the "fixed" obsolete version of tzdata and ensure
;; it does not sneak in to the closure.
- #:disallowed-references (,tzdata-2017a)
+ #:disallowed-references (,tzdata-for-tests)
#:phases (modify-phases %standard-phases
(add-before 'check 'check-setup
(lambda* (#:key inputs #:allow-other-keys)
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 6cf235960c..4c7f320f6b 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -171,9 +171,9 @@ shared NFS home directories.")
("python" ,python-wrapper)
("perl" ,perl) ; needed by GIO tests
("bash" ,bash)
- ("tzdata" ,tzdata-2017a))) ; for tests/gdatetime.c
+ ("tzdata" ,tzdata-for-tests))) ; for tests/gdatetime.c
(arguments
- `(#:disallowed-references (,tzdata-2017a)
+ `(#:disallowed-references (,tzdata-for-tests)
#:phases
(modify-phases %standard-phases
(add-before 'build 'pre-build
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 196541a2e3..67c15146f9 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -9841,7 +9841,8 @@ in Perl source files.")
(base32 "1lgfr87j4qwqnln0hyyzgik5ixqslzdaksn9m8y824gqbcihc6ic"))))
(build-system perl-build-system)
(arguments
- `(#:phases
+ `(#:disallowed-references (,tzdata-for-tests)
+ #:phases
(modify-phases %standard-phases
;; This is needed for tests
(add-after 'unpack 'set-TZDIR
@@ -9851,7 +9852,7 @@ in Perl source files.")
#t)))))
(native-inputs
`(("perl-module-build" ,perl-module-build)
- ("tzdata" ,tzdata-2017a)))
+ ("tzdata" ,tzdata-for-tests)))
(home-page "https://metacpan.org/release/Time-ParseDate")
(synopsis "Collection of Perl modules for time/date manipulation")
(description "Provides several perl modules for date/time manipulation:
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 3367c7aa46..8ebb16a03c 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -119,7 +119,7 @@ be output in text, PostScript, PDF or HTML.")
"0r0cv2kc3x5z9xycpnxx6fbvv22psw2m342jhpslbxkc8g1307lp"))))
(build-system gnu-build-system)
(arguments
- `(#:disallowed-references (,tzdata-2017a)
+ `(#:disallowed-references (,tzdata-for-tests)
#:make-flags
(list (string-append "LDFLAGS=-Wl,-rpath="
(assoc-ref %outputs "out")
@@ -244,7 +244,7 @@ be output in text, PostScript, PDF or HTML.")
("perl" ,perl)
("pkg-config" ,pkg-config)
("texinfo" ,texinfo) ; for building HTML manuals
- ("tzdata" ,tzdata-2017a)
+ ("tzdata" ,tzdata-for-tests)
("xz" ,xz)))
(inputs
`(;; We need not only cairo here, but pango to ensure that tests for the