summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorChristopher Allan Webber <cwebber@dustycloud.org>2016-01-18 11:25:16 -0800
committerChristopher Allan Webber <cwebber@dustycloud.org>2016-01-18 21:51:45 -0800
commit34dd26af491f49949b606377dcb540af15f2125a (patch)
tree0a0fc9ca0e16be409cbc919e3350d1529df5e06b /gnu/packages
parent1348185ac2bb48b373495830267cff8ddc6b1fa5 (diff)
gnu: Add fdm.
* gnu/packages/mail.scm (fdm): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/mail.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index f765728ae4..efe886d2f8 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016 Christopher Allan Webber <cwebber@dustycloud.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1013,4 +1014,32 @@ compatibility shims for the @command{sendmail}, @command{mailq}, and
@command{newaliases} commands.")
(license gpl2+)))
+(define-public fdm
+ (package
+ (name "fdm")
+ (version "1.9")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/nicm/fdm/releases/download/"
+ version "/fdm-"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "054rscijahiza5f9qha79rg3siji3bk5mk10f8c2vqx7m4w6qh8n"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("tdb" ,tdb)
+ ("openssl" ,openssl)
+ ("zlib" ,zlib)))
+ (home-page "https://github.com/nicm/fdm")
+ (synopsis "Mail Retrieval Agent (MRA) and Mail Delivery Agent (MDA)")
+ (description "fdm is a program designed to fetch mail from POP3
+or IMAP servers, or receive local mail from stdin, and
+deliver it in various ways.")
+ (license
+ ;; Why point to a source file? Well, all the individual files have a
+ ;; copy of this license in their headers, but there's no seprate file
+ ;; with that information.
+ (non-copyleft "file://command.c"))))
+
;;; mail.scm ends here