summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-01-21 02:12:40 -0500
committerLeo Famulari <leo@famulari.name>2016-01-21 18:11:12 -0500
commit45da8c6dd10c93280277d17463d09fce6a25afe9 (patch)
treedeb503ad1dd99e44920227df0c400309cc0d6695 /gnu/packages
parentc74f0cb2b871f59466e6fbfbc954d8fc1cbc3c9c (diff)
gnu: Add iftop.
* gnu/packages/admin.scm (iftop): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/admin.scm23
-rw-r--r--gnu/packages/zsh.scm56
2 files changed, 57 insertions, 22 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 6e783502e6..953c5b4cf8 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
;;; Copyright © 2015 Alex Sassmannshausen <alex.sassmannshausen@gmail.com>
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
+;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1377,3 +1378,25 @@ command that learns\". It works by maintaining a database of the directories
you use the most from the command line and allows you to \"jump\" to
frequently used directories by typing only a small pattern.")
(license license:gpl3+)))
+
+(define-public iftop
+ (package
+ (name "iftop")
+ (version "1.0pre4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.ex-parrot.com/~pdw/iftop/download"
+ "/iftop-" version ".tar.gz"))
+ (sha256
+ (base32
+ "15sgkdyijb7vbxpxjavh5qm5nvyii3fqcg9mzvw7fx8s6zmfwczp"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("libpcap" ,libpcap)
+ ("ncurses" ,ncurses)))
+ (synopsis "Monitor network usage")
+ (description "Iftop does for network usage what @command{top} does
+for CPU usage. It listens to network traffic on a named interface and
+displays a table of current bandwidth usage by pairs of hosts.")
+ (home-page "http://www.ex-parrot.com/~pdw/iftop/")
+ (license license:gpl3)))
diff --git a/gnu/packages/zsh.scm b/gnu/packages/zsh.scm
index 6d25fd4671..2ce36d066b 100644
--- a/gnu/packages/zsh.scm
+++ b/gnu/packages/zsh.scm
@@ -23,6 +23,7 @@
#:use-module (gnu packages autotools)
#:use-module (guix packages)
#:use-module (guix download)
+; #:use-module (guix build utils)
#:use-module (guix build-system gnu)
#:use-module (guix licenses))
@@ -42,28 +43,39 @@
(base32
"11shllzhq53fg8ngy3bgbmpf09fn2czifg7hsb41nxi3410mpvcl"))))
(build-system gnu-build-system)
- (arguments `(#:configure-flags '("--with-tcsetpgrp" "--enable-pcre")
- #:phases (alist-cons-before
- 'configure 'fix-sh
- (lambda _
- ;; Some of the files are ISO-8859-1 encoded.
- (with-fluids ((%default-port-encoding #f))
- (substitute*
- '("configure"
- "configure.ac"
- "Src/exec.c"
- "Src/mkmakemod.sh"
- "Config/installfns.sh"
- "Config/defs.mk.in"
- "Test/E01options.ztst"
- "Test/A05execution.ztst"
- "Test/A01grammar.ztst"
- "Test/A06assign.ztst"
- "Test/B02typeset.ztst"
- "Completion/Unix/Command/_init_d"
- "Util/preconfig")
- (("/bin/sh") (which "sh")))))
- %standard-phases)))
+ (arguments `(#:parallel-build? #f
+ #:configure-flags '("--with-tcsetpgrp" "--enable-pcre")
+ #:make-flags '("ZTST_verbose=2")
+ #:phases (modify-phases %standard-phases
+ (add-before 'configure 'fix-sh
+ (lambda _
+ ;; Some of the files are ISO-8859-1 encoded.
+ (with-fluids ((%default-port-encoding #f))
+ (substitute*
+ '("configure"
+ "configure.ac"
+ "Src/exec.c"
+ "Src/mkmakemod.sh"
+ "Config/installfns.sh"
+ "Config/defs.mk.in"
+ "Test/E01options.ztst"
+ "Test/A05execution.ztst"
+ "Test/A01grammar.ztst"
+ "Test/A06assign.ztst"
+ "Test/B02typeset.ztst"
+ "Completion/Unix/Command/_init_d"
+ "Util/preconfig")
+ (("/bin/sh") (which "sh"))))))
+; (add-before 'check 'provide-zsh-interpreter
+; (lambda _
+; (substitute* "Test/runtests.zsh"
+; (("#!/bin/zsh -f")
+; (string-append "#!" (getcwd) "/Src/zsh -f")))
+; (substitute* "Test/ztst.zsh"
+; (("#!/bin/zsh -f")
+; (string-append "#!" (getcwd) "/Src/zsh -f")))
+; ))
+ )))
(native-inputs `(("autoconf", autoconf)))
(inputs `(("ncurses", ncurses)
("pcre", pcre)