summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-02-07 16:55:20 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:58:40 +0200
commitaf6d3c5cc046b200f792e745dc94797c6ae19f9e (patch)
tree540b2d0bcb6ceb8a081155d6a12e97517014d717 /gnu/packages
parent950dbf26d3d26d1b3ba2716dc987afac740e2dbc (diff)
gnu: Add rust-tokio-tungstenite-0.20.
* gnu/packages/crates-io.scm (rust-tokio-tungstenite-0.20): New variable. (rust-tokio-tungstenite-0.19): Inherit from rust-tokio-tungstenite-0.20. Change-Id: If79f6ff2afff609aa4b7cb70e8597ec45f5e63a2
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm45
1 files changed, 37 insertions, 8 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index e51ada701c..c1ce26ce82 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -69969,8 +69969,44 @@ implementation of TLS for nonblocking I/O streams.")
("rust-security-framework" ,rust-security-framework-0.2)
("rust-tokio" ,rust-tokio-0.1))))))
+(define-public rust-tokio-tungstenite-0.20
+ (package
+ (name "rust-tokio-tungstenite")
+ (version "0.20.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "tokio-tungstenite" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0v1v24l27hxi5hlchs7hfd5rgzi167x0ygbw220nvq0w5b5msb91"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-futures-util" ,rust-futures-util-0.3)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-native-tls" ,rust-native-tls-0.2)
+ ("rust-rustls" ,rust-rustls-0.21)
+ ("rust-rustls-native-certs" ,rust-rustls-native-certs-0.6)
+ ("rust-tokio" ,rust-tokio-1)
+ ("rust-tokio-native-tls" ,rust-tokio-native-tls-0.3)
+ ("rust-tokio-rustls" ,rust-tokio-rustls-0.24)
+ ("rust-tungstenite" ,rust-tungstenite-0.20)
+ ("rust-webpki-roots" ,rust-webpki-roots-0.25))
+ #:cargo-development-inputs (("rust-env-logger" ,rust-env-logger-0.10)
+ ("rust-futures-channel" ,rust-futures-channel-0.3)
+ ("rust-hyper" ,rust-hyper-0.14)
+ ("rust-tokio" ,rust-tokio-1)
+ ("rust-url" ,rust-url-2))))
+ (home-page "https://github.com/snapview/tokio-tungstenite")
+ (synopsis "Tokio binding for Tungstenite")
+ (description
+ "This package provides Tokio binding for Tungstenite, the lightweight
+stream-based @code{WebSocket} implementation.")
+ (license license:expat)))
+
(define-public rust-tokio-tungstenite-0.19
(package
+ (inherit rust-tokio-tungstenite-0.20)
(name "rust-tokio-tungstenite")
(version "0.19.0")
(source
@@ -69980,7 +70016,6 @@ implementation of TLS for nonblocking I/O streams.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32 "0b5iqjsprll88912jqb36xbjcflmgl907w3lgi14634sdv4rll7c"))))
- (build-system cargo-build-system)
(arguments
`(#:cargo-inputs
(("rust-futures-util" ,rust-futures-util-0.3)
@@ -69998,13 +70033,7 @@ implementation of TLS for nonblocking I/O streams.")
("rust-futures-channel", rust-futures-channel-0.3)
("rust-hyper" ,rust-hyper-0.14)
("rust-tokio" ,rust-tokio-1)
- ("rust-url" ,rust-url-2))))
- (home-page "https://github.com/snapview/tokio-tungstenite")
- (synopsis "Tokio binding for Tungstenite")
- (description
- "This package provides Tokio binding for Tungstenite, the lightweight
-stream-based WebSocket implementation.")
- (license license:expat)))
+ ("rust-url" ,rust-url-2))))))
(define-public rust-tokio-tungstenite-0.11
(package