summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2023-10-01 22:01:29 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2023-10-01 22:01:29 +0200
commitf4a5d4f0b0a814fe8bb19063cb77cbaa45d85032 (patch)
treeda999920b831dee704dfcf7ac99ee1cfd6cc6367 /gnu/packages
parent009921438672a412ff027f182bffc997be04ff21 (diff)
gnu: poetry: Fix build.
Follow-up to 21d6985a8b3c6e53aab648275dc27b72c7453437. * gnu/packages/python-build.scm (python-poetry-core-1.0): New variable. * gnu/packages/python-xyz.scm (poetry)[propagated-inputs]: Replace python-poetry-core by python-poetry-core-1.0.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-build.scm20
-rw-r--r--gnu/packages/python-xyz.scm2
2 files changed, 21 insertions, 1 deletions
diff --git a/gnu/packages/python-build.scm b/gnu/packages/python-build.scm
index 154c97e9e4..bb1df3e9aa 100644
--- a/gnu/packages/python-build.scm
+++ b/gnu/packages/python-build.scm
@@ -493,6 +493,26 @@ any dependency management. It aims to keep dependencies to a minimum, in
order to make bootstrapping easier.")
(license license:expat)))
+(define-public python-poetry-core-1.0
+ (package
+ (name "python-poetry-core")
+ (version "1.0.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "poetry-core" version))
+ (sha256
+ (base32 "01n2rbsvks7snrq3m1d08r3xz9q2715ajb62fdb6rvqnb9sirhcq"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/python-poetry/poetry-core")
+ (synopsis "Poetry PEP 517 build back-end")
+ (description
+ "The @code{poetry-core} module provides a PEP 517 build back-end
+implementation developed for Poetry. This project is intended to be
+a light weight, fully compliant, self-contained package allowing PEP 517
+compatible build front-ends to build Poetry managed projects.")
+ (license license:expat)))
+
(define-public python-poetry-core
(package
(name "python-poetry-core")
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a40738f5cc..3f2828fe54 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19316,7 +19316,7 @@ database, file, dict stores. Cachy supports python versions 2.7+ and 3.2+.")
python-pexpect
python-pip
python-pkginfo
- python-poetry-core
+ python-poetry-core-1.0
python-requests
python-requests-toolbelt
python-shellingham