summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJohn Darrington <john@darrington.wattle.id.au>2013-12-17 20:33:26 +0100
committerLudovic Courtès <ludo@gnu.org>2013-12-17 21:28:07 +0100
commitdb6190899ea15d3b66d6b2d82bdeaee442423100 (patch)
tree84ca4ed404ea6fdb6c127d940f9cb73f2c8431b8 /gnu/packages
parentf22e0e264e400b69fc91509c676f9069b7cdbc2e (diff)
gnu: gnu-build-system: Add CC_FOR_BUILD to configure flags.
* guix/build/gnu-build-system.scm: Add new configure flag: CC_FOR_BUILD=gcc * gnu/packages/gnupg.scm, gnu/packages/guile.scm, gnu/packages/make-bootstrap.scm: remove CC_FOR_BUILD from these package descriptions. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gnupg.scm4
-rw-r--r--gnu/packages/guile.scm6
-rw-r--r--gnu/packages/make-bootstrap.scm5
3 files changed, 2 insertions, 13 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index fb7b4975ac..be13eb0ba0 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -44,10 +44,6 @@
(base32
"0pz58vr12qihq2f0bypjxsb6cf6ajq5258fmfm8s6lvwm3b9xz6a"))))
(build-system gnu-build-system)
- (arguments
- (if (%current-target-system)
- '(#:configure-flags '("CC_FOR_BUILD=gcc"))
- '()))
(home-page "http://gnupg.org")
(synopsis
"Libgpg-error, a small library that defines common error values for all GnuPG components")
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 40d9ae7df8..3dbb5d8429 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -150,11 +150,7 @@ without requiring the source code to be rewritten.")
(substitute* "module/ice-9/popen.scm"
(("/bin/sh")
(string-append bash "/bin/bash")))))
- %standard-phases)
-
- ,@(if (%current-target-system)
- '(#:configure-flags '("CC_FOR_BUILD=gcc"))
- '())))
+ %standard-phases)))
(native-search-paths
(list (search-path-specification
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index d621a634a3..97a13b4b74 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -502,10 +502,7 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
`(;; When `configure' checks for ltdl availability, it
;; doesn't try to link using libtool, and thus fails
;; because of a missing -ldl. Work around that.
- #:configure-flags '("LDFLAGS=-ldl"
- ,@(if (%current-target-system)
- '("CC_FOR_BUILD=gcc")
- '()))
+ #:configure-flags '("LDFLAGS=-ldl")
#:phases (alist-cons-before
'configure 'static-guile