summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-12-19 15:28:40 -0500
committerMark H Weaver <mhw@netris.org>2014-12-19 23:28:15 -0500
commit2750ee5b0d207d98236605b0d8ff8fe25109269a (patch)
tree497b76d5136b3ceeada99d1253a5b64151d14d03 /gnu/packages
parent9b1cd1e56a8669398bf53380574f48d549f5b726 (diff)
gnu: xf86-input-synaptics: Update to 1.8.1.
* gnu/packages/patches/xf86-input-synaptics-glibc-2.20.patch: Remove. * gnu-system.am (dist_patch_DATA): Remove it. * gnu/packages/xorg.scm (xf86-input-synaptics): Update to 1.8.1. Remove patch. Add libevdev to inputs.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/patches/xf86-input-synaptics-glibc-2.20.patch63
-rw-r--r--gnu/packages/xorg.scm9
2 files changed, 4 insertions, 68 deletions
diff --git a/gnu/packages/patches/xf86-input-synaptics-glibc-2.20.patch b/gnu/packages/patches/xf86-input-synaptics-glibc-2.20.patch
deleted file mode 100644
index 93263e1f19..0000000000
--- a/gnu/packages/patches/xf86-input-synaptics-glibc-2.20.patch
+++ /dev/null
@@ -1,63 +0,0 @@
-Allow builds with libc 2.20.
-Patch from <https://raw.githubusercontent.com/openembedded/oe-core/master/meta/recipes-graphics/xorg-driver/xf86-input-synaptics/always_include_xorg_server.h.patch>.
-
-From 96e60a4ea242d2decf109835981ae186cc36f642 Mon Sep 17 00:00:00 2001
-From: Peter Hutterer <peter.hutterer@who-t.net>
-Date: Fri, 29 Aug 2014 07:57:41 +1000
-Subject: Include xorg-server.h to fix build errors on newest glibc
-
-In file included from /usr/include/string.h:634:0,
- from /usr/include/xorg/os.h:53,
- from /usr/include/xorg/misc.h:115,
- from /usr/include/xorg/xf86str.h:37,
- from /usr/include/xorg/xf86Xinput.h:54,
- from synproto.h:36,
- from synproto.c:24:
-/usr/include/xorg/os.h:579:1: error: expected identifier or '(' before '__extension__'
- strndup(const char *str, size_t n);
-
-See http://lists.freedesktop.org/archives/xorg-devel/2014-July/043070.html
-
-Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
-
-Status: Backport
-
-Index: xf86-input-synaptics-1.8.0/src/eventcomm.h
-===================================================================
---- xf86-input-synaptics-1.8.0.orig/src/eventcomm.h 2014-08-28 18:40:28.628070587 -0700
-+++ xf86-input-synaptics-1.8.0/src/eventcomm.h 2014-08-28 18:40:28.620070587 -0700
-@@ -27,6 +27,8 @@
- #ifndef _EVENTCOMM_H_
- #define _EVENTCOMM_H_
-
-+#include <xorg-server.h>
-+
- #include <linux/input.h>
- #include <linux/version.h>
- #include <xf86Xinput.h>
-Index: xf86-input-synaptics-1.8.0/src/ps2comm.h
-===================================================================
---- xf86-input-synaptics-1.8.0.orig/src/ps2comm.h 2014-08-28 18:40:28.628070587 -0700
-+++ xf86-input-synaptics-1.8.0/src/ps2comm.h 2014-08-28 18:40:28.620070587 -0700
-@@ -22,6 +22,8 @@
- #ifndef _PS2COMM_H_
- #define _PS2COMM_H_
-
-+#include <xorg-server.h>
-+
- #include <unistd.h>
- #include <sys/ioctl.h>
- #include "xf86_OSproc.h"
-Index: xf86-input-synaptics-1.8.0/src/synproto.h
-===================================================================
---- xf86-input-synaptics-1.8.0.orig/src/synproto.h 2014-08-28 18:40:28.628070587 -0700
-+++ xf86-input-synaptics-1.8.0/src/synproto.h 2014-08-28 18:40:28.624070587 -0700
-@@ -31,6 +31,8 @@
- #include "config.h"
- #endif
-
-+#include <xorg-server.h>
-+
- #include <unistd.h>
- #include <sys/ioctl.h>
- #include <xf86Xinput.h>
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 0125dfbbdf..78fdc21e02 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -2301,22 +2301,21 @@ devices, thus making direct access unnecessary.")
(define-public xf86-input-synaptics
(package
(name "xf86-input-synaptics")
- (version "1.6.1")
+ (version "1.8.1")
(source
(origin
(method url-fetch)
(uri (string-append
- "mirror://xorg/X11R7.7/src/everything/xf86-input-synaptics-"
+ "mirror://xorg/individual/driver/xf86-input-synaptics-"
version
".tar.bz2"))
(sha256
(base32
- "0g5b1s6q1dg38l8y47cwg7cs5nivwj0agmp71g273ws0lfg4bc8s"))
- (patches
- (list (search-patch "xf86-input-synaptics-glibc-2.20.patch")))))
+ "16phzd7yhl4wns957c35qz2nahmjvnlx05jf975s524qkvrdlkyp"))))
(build-system gnu-build-system)
(inputs `(("libx11" ,libx11)
("libxi" ,libxi)
+ ("libevdev" ,libevdev)
("mtdev" ,mtdev)
("xorg-server" ,xorg-server)))
(native-inputs `(("pkg-config" ,pkg-config)))