summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2020-06-02 22:46:01 -0700
committerVagrant Cascadian <vagrant@debian.org>2020-06-08 13:05:44 -0700
commit21569e53b2fcbd00ad458898ad170be6edef315e (patch)
treefbab836b99df034807bd1365fd88670b444b51cf /gnu/packages
parent838c4b10e9905e1957a57a281152599c1cdd17ce (diff)
gnu: Add linux-libre 5.7.1.
* gnu/packages/linux (deblob-scripts-5.7): New variable. (linux-libre-5.7-version): New variable. (linux-libre-5.7-pristine-source): New variable. (linux-libre-5.7-source): New variable. (linux-libre-headers-5.7): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/linux.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 329bf7c327..f5329445cf 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -193,6 +193,12 @@ defconfig. Return the appropriate make target if applicable, otherwise return
"deblob-check"))
(sha256 deblob-check-hash))))
+(define deblob-scripts-5.7
+ (linux-libre-deblob-scripts
+ "5.7.1"
+ (base32 "1c0n39wg6xij4x63ppg0m80kfcffkn3iilm3chyiix09n9g7vb78")
+ (base32 "02is246xaql1br3kizqicrkp982nw4gdwpn7nlzjazvsmyd1hcv2")))
+
(define deblob-scripts-5.6
(linux-libre-deblob-scripts
"5.6.7"
@@ -370,6 +376,14 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(sha256 hash)))
+(define-public linux-libre-5.7-version "5.7.1")
+(define-public linux-libre-5.7-pristine-source
+ (let ((version linux-libre-5.7-version)
+ (hash (base32 "1vcxrrb2i4366iciw0mfahwbdrzmhrrsr7gi4vdkzznfv2niils0")))
+ (make-linux-libre-source version
+ (%upstream-linux-source version hash)
+ deblob-scripts-5.7)))
+
(define-public linux-libre-5.6-version "5.6.17")
(define-public linux-libre-5.6-pristine-source
(let ((version linux-libre-5.6-version)
@@ -446,6 +460,11 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(patches (append (origin-patches source)
patches))))
+(define-public linux-libre-5.7-source
+ (source-with-patches linux-libre-5.7-pristine-source
+ (list %boot-logo-patch
+ %linux-libre-arm-export-__sync_icache_dcache-patch)))
+
(define-public linux-libre-5.6-source
(source-with-patches linux-libre-5.6-pristine-source
(list %boot-logo-patch
@@ -554,6 +573,10 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(description "Headers of the Linux-Libre kernel.")
(license license:gpl2)))
+(define-public linux-libre-headers-5.7
+ (make-linux-libre-headers* linux-libre-5.7-version
+ linux-libre-5.7-source))
+
(define-public linux-libre-headers-5.6
(make-linux-libre-headers* linux-libre-5.6-version
linux-libre-5.6-source))