summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2016-01-16 22:12:23 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-04-30 15:46:24 +1000
commit324efb88880834bbe9bb55387b63dafd600e93e9 (patch)
tree5d388e2f69e6de0c9f177cf7e736ae0a182e60c7 /gnu/packages
parent6c0e2dbbf342967e20855ab3d17a23593e36af6a (diff)
gnu: Add muscle.
* gnu/packages/bioinformatics.scm (muscle): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioinformatics.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 620439f144..079fd467cc 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2548,6 +2548,41 @@ RNA-Seq, the MISO model uses Bayesian inference to compute the probability
that a read originated from a particular isoform.")
(license license:gpl2)))
+(define-public muscle
+ (package
+ (name "muscle")
+ (version "3.8.1551")
+ (source (origin
+ (method url-fetch/tarbomb)
+ (file-name (string-append name "-" version))
+ (uri (string-append
+ "http://www.drive5.com/muscle/muscle_src_"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0bj8kj7sdizy3987zx6w7axihk40fk8rn76mpbqqjcnd64i5a367"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags (list "LDLIBS = -lm")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'check
+ ;; There are no tests, so just test if it runs.
+ (lambda _ (zero? (system* "./muscle" "-version"))))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ (install-file "muscle" bin)))))))
+ (home-page "http://www.drive5.com/muscle")
+ (synopsis "Multiple sequence alignment program")
+ (description
+ "MUSCLE aims to be a fast and accurate multiple sequence alignment
+program for nucleotide and protein sequences.")
+ ;; License information found in 'muscle -h' and usage.cpp.
+ (license license:public-domain)))
+
(define-public orfm
(package
(name "orfm")