summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-25 16:19:40 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-25 16:19:40 +0100
commit3e41919d5123ec7a5772ec2828a157ec64cfb947 (patch)
treeab7c789a2332e97d4c436db8bde05d7ddf3223a2 /gnu/packages
parentc538bcdd38ca12fbdf02b220a371ac16448cab8c (diff)
gnu: Add r-heatplus.
* gnu/packages/bioconductor.scm (r-heatplus): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioconductor.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 744fc8780d..a17372da82 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2619,3 +2619,28 @@ alignments (BAM files) or datasets of called variants. The user is expected
to have already aligned the reads with a separate tool, e.g., GSNAP via
gmapR.")
(license license:artistic2.0)))
+
+(define-public r-heatplus
+ (package
+ (name "r-heatplus")
+ (version "2.28.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "Heatplus" version))
+ (sha256
+ (base32
+ "0drspjzgb23ra2kdvpxhsd8mdifsf97fcf668llyz2hr0r39fc48"))))
+ (properties `((upstream-name . "Heatplus")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-rcolorbrewer" ,r-rcolorbrewer)))
+ (home-page "https://github.com/alexploner/Heatplus")
+ (synopsis "Heatmaps with row and/or column covariates and colored clusters")
+ (description
+ "This package provides tools to display a rectangular heatmap (intensity
+plot) of a data matrix. By default, both samples (columns) and features (row)
+of the matrix are sorted according to a hierarchical clustering, and the
+corresponding dendrogram is plotted. Optionally, panels with additional
+information about samples and features can be added to the plot.")
+ (license license:gpl2+)))