summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2017-10-09 06:57:26 +0100
committerChristopher Baines <mail@cbaines.net>2018-03-03 12:51:23 +0000
commit433dc74611b0338ae15c7a7dc344a802c5667a34 (patch)
treee2c2c14000a46e9461c5556330cb02743e910bbb /gnu/packages
parentadd928d35fb7a182662ecfdf261cc6a4c98b3c67 (diff)
gnu: networking: Add czmq.
* gnu/packages/networking.scm (czmq): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/networking.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index d4c9d40d7a..3c18620bd2 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -267,6 +267,42 @@ filtering (subscriptions), seamless access to multiple transport protocols and
more.")
(license license:lgpl3+)))
+(define-public czmq
+ (package
+ (name "czmq")
+ (version "4.1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/zeromq/" name
+ "/releases/download/v" version
+ "/" name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "04gwf61rijwm6b2wblwv8gky1gdrbfmg1d19hf72kdc691ds7vrv"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(;; TODO Tests fail for some reason:
+ ;; * zauth: OK
+ ;; * zbeacon: OK (skipping test, no UDP broadcasting)
+ ;; E: (czmq_selftest) 18-02-24 16:25:52 No broadcast interface found, (ZSYS_INTERFACE=lo)
+ ;; make[2]: *** [Makefile:2245: check-local] Segmentation fault
+ ;; make[2]: Leaving directory '/tmp/guix-build-czmq-4.1.0.drv-0/czmq-4.1.0'
+ ;; make[1]: *** [Makefile:2032: check-am] Error 2
+ ;; make[1]: Leaving directory '/tmp/guix-build-czmq-4.1.0.drv-0/czmq-4.1.0'
+ ;; make: *** [Makefile:1588: check-recursive] Error 1
+ ;; phase `check' failed after 19.4 seconds
+ #:tests? #f
+ #:configure-flags '("--enable-drafts")))
+ (inputs
+ `(("zeromq" ,zeromq)))
+ (home-page "http://zeromq.org")
+ (synopsis "High-level C bindings for ØMQ")
+ (description
+ "czmq provides bindings for the ØMQ core API that hides the differences
+between different versions of ØMQ.")
+ (license license:mpl2.0)))
+
(define-public librdkafka
(package
(name "librdkafka")