summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-11-01 13:20:41 +0100
committerRicardo Wurmus <rekado@elephly.net>2016-11-04 21:23:05 +0100
commita0d62280f56050848b8f021db28c857a56d6f7dc (patch)
tree660e2b73268b346a4d2dd48caef2e024211535cf /gnu/packages
parentc60898a845301f2ac1c8845c843907cb6e98224e (diff)
gnu: Add python-notebook.
* gnu/packages/python.scm (python-notebook, python2-notebook): New variables.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 7a5f3a3aba..453e7e689a 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6804,6 +6804,44 @@ convert an @code{.ipynb} notebook file into various static formats including:
(define-public python2-nbconvert
(package-with-python2 python-nbconvert))
+(define-public python-notebook
+ (package
+ (name "python-notebook")
+ (version "4.2.3")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "notebook" version))
+ (sha256
+ (base32
+ "0laq5c2f21frq6xcdckgq7raqhznbjb0qs0357g612z87wyn1a9r"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ ;; HOME must be set for tests
+ (setenv "HOME" "/tmp")
+ (zero? (system* "nosetests")))))))
+ (propagated-inputs
+ `(("python-jupyter-core" ,python-jupyter-core)
+ ("python-nbformat" ,python-nbformat)
+ ("python-nbconvert" ,python-nbconvert)
+ ("python-ipython" ,python-ipython)))
+ (native-inputs
+ `(("python-nose" ,python-nose)
+ ("python-sphinx" ,python-sphinx)
+ ("python-requests" ,python-requests)))
+ (home-page "http://jupyter.org/")
+ (synopsis "Web-based notebook environment for interactive computing")
+ (description
+ "The Jupyter HTML notebook is a web-based notebook environment for
+interactive computing.")
+ (license license:bsd-3)))
+
+(define-public python2-notebook
+ (package-with-python2 python-notebook))
+
(define-public python-chardet
(package
(name "python-chardet")