summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-11-01 13:20:34 +0100
committerRicardo Wurmus <rekado@elephly.net>2016-11-04 11:23:19 +0100
commitab526102ed7f0af0fe607cb2d1ba1fbd7f791582 (patch)
treed9d6d8c6979769537af551a2c8a1b2462a60e922 /gnu/packages
parent9ff01f2d018d65f01b1a6a66bd28c26f196719bc (diff)
gnu: Add python-ipykernel.
* gnu/packages/python.scm (python-ipykernel, python2-ipykernel): New variables.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 0f1697820d..da2d48417b 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4557,6 +4557,32 @@ installing @code{kernelspec}s for use with Jupyter frontends.")
(define-public python2-jupyter-client
(package-with-python2 python-jupyter-client))
+(define-public python-ipykernel
+ (package
+ (name "python-ipykernel")
+ (version "4.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ipykernel" version))
+ (sha256
+ (base32 "15c2bp1x3i6s4xb7vz7742h3kmvdfdfn9n2haywm3mwgvf77jni4"))))
+ (build-system python-build-system)
+ ;; The tests load a submodule of IPython. However, IPython itself depends
+ ;; on ipykernel.
+ (arguments `(#:tests? #f))
+ (propagated-inputs
+ ;; imported at runtime during connect
+ `(("python-jupyter-client" ,python-jupyter-client)))
+ (home-page "http://ipython.org")
+ (synopsis "IPython Kernel for Jupyter")
+ (description
+ "This package provides the IPython kernel for Jupyter.")
+ (license license:bsd-3)))
+
+(define-public python2-ipykernel
+ (package-with-python2 python-ipykernel))
+
(define-public python-ipython
(package
(name "python-ipython")