summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2016-11-29 20:33:30 +0300
committerAlex Kost <alezost@gmail.com>2016-12-04 17:39:48 +0300
commitc3a10d30d15d7f4b70c9f23cc20a498079fcf77f (patch)
tree0983dee62af7f22e522777f001a699a220c44900 /gnu/packages
parentc44ec4a8b401a41ac1d9c089ba573b3ae5437d66 (diff)
gnu: emms: Update to 4.2.
* gnu/packages/emacs.scm (emms): Update to 4.2. [arguments]: EMMS installs "emms-print-metadata" now but assumes that BINDIR exists, so do not install it manually in 'post-install' phase, and make "/bin" directory in 'pre-install' phase.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs.scm17
1 files changed, 7 insertions, 10 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 6936f7dd11..4afe67a7f5 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -897,14 +897,14 @@ provides an optional IDE-like error list.")
(define-public emms
(package
(name "emacs-emms")
- (version "4.1")
+ (version "4.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/emms/emms-"
version ".tar.gz"))
(sha256
(base32
- "0ay6631p3dr6xnhkm7skwn0gp317r1mxbip28m126w4zqf05cbh3"))
+ "1xa9y64g5z8gfnxk1c2rf3plfjhqn4r6j8dpiygnfs6w4giysn22"))
(modules '((guix build utils)))
(snippet
'(substitute* "Makefile"
@@ -974,22 +974,19 @@ provides an optional IDE-like error list.")
(string-append "\"" mp3info "/bin/mp3info\"")))))))
(add-before 'install 'pre-install
(lambda* (#:key outputs #:allow-other-keys)
- ;; The 'install' rule expects the target directory to exist.
+ ;; The 'install' rule expects the target directories to exist.
(let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
(man1 (string-append out "/share/man/man1")))
+ (mkdir-p bin)
(mkdir-p man1)
#t)))
(add-after 'install 'post-install
(lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (target (string-append
- out "/bin/emms-print-metadata")))
+ (let ((out (assoc-ref outputs "out")))
(symlink "emms-auto.el"
(string-append out "/share/emacs/site-lisp/"
- "emms-autoloads.el"))
- (mkdir-p (dirname target))
- (copy-file "src/emms-print-metadata" target)
- (chmod target #o555)))))
+ "emms-autoloads.el"))))))
#:tests? #f))
(native-inputs `(("emacs" ,emacs-minimal) ;for (guix build emacs-utils)
("texinfo" ,texinfo)))