summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorHendursaga <hendursaga@yahoo.com>2020-08-31 21:22:54 +0000
committerLudovic Courtès <ludo@gnu.org>2020-09-02 17:17:37 +0200
commit2056226557f977c70691aadcd57dbb81bca5058b (patch)
treedbb9bc6fa94a5fc8f3118ba2ba07202507f6f39a /gnu/packages
parentc9a86e666f8ae7d15bb13d730b6949e7113c3d90 (diff)
gnu: Add knockd.
* gnu/packages/networking.scm (knockd): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/networking.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 1340bef8f0..8b18de6121 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -379,6 +379,28 @@ sockets, and also some helper utilities around SCTP.")
;; Others.
license:gpl2+))))
+(define-public knockd
+ (package
+ (name "knockd")
+ (version "0.7")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://www.zeroflux.org/proj/knock/files/knock-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "193qcpsy7v51c6awhg9652l5blyz8vp6n7y6fi7l4rhh6af4ff4r"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("libpcap" ,libpcap)))
+ (home-page "https://www.zeroflux.org/projects/knock")
+ (synopsis "Small port-knock daemon")
+ (description "@command{knockd} is a port-knock daemon. It listens to all traffic on
+an ethernet or PPP interface, looking for special \"knock\" sequences of @dfn{port-hits}
+(UDP/TCP packets sent to a server port). This port need not be open, since knockd listens
+at the link-layer level.")
+ (license license:gpl2+)))
+
(define-public nng
(package
(name "nng")