summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-05-22 06:22:10 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-08-18 22:53:59 +0200
commit72fd1b3f11b28ee7edc18011ed18cfa3b86a96f7 (patch)
tree203c6594b4c76cfeef731e5d06be48904f805b36 /gnu/packages
parent08684798a8b51f0ce618860c2aeae7db5d70be63 (diff)
gnu: Add portablexdr.
* gnu/packages/gnome.scm (portablexdr): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gnome.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index fc63341bcb..34801a054c 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -141,6 +141,7 @@
#:use-module (gnu packages ninja)
#:use-module (gnu packages nss)
#:use-module (gnu packages openldap)
+ #:use-module (gnu packages package-management)
#:use-module (gnu packages password-utils)
#:use-module (gnu packages pcre)
#:use-module (gnu packages pdf)
@@ -259,6 +260,31 @@ Desktop. It is designed to be as simple as possible and has some unique
features to enable users to create their discs easily and quickly.")
(license license:gpl2+)))
+(define-public portablexdr
+ (package
+ (name "portablexdr")
+ (version "4.9.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://people.redhat.com/~rjones/" name "/files/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0b77ipvvi520nv7rr6jb1c3xryhc3m2mywhby7m48kfgag8vvx2w"))))
+ (build-system gnu-build-system)
+ (synopsis "External Data Representation Library")
+ (description "PortableXDR is an implementation of External Data
+Representation (XDR) Library. It is a standard data serialization format, for
+uses such as computer network protocols. It allows data to be transferred
+between different kinds of computer systems.")
+ (home-page "https://people.redhat.com/~rjones/portablexdr/")
+ (license
+ (list
+ license:gpl2+
+ license:lgpl2.1+))))
+
(define-public tepl
(package
(name "tepl")