summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2019-10-05 20:42:48 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2019-10-13 22:29:42 +0300
commit735a972eaee88a693557e1b2a6cdb3fcba9c6b68 (patch)
tree78a3e39d76ea76495ebb80836e7f8fe137365819 /gnu/packages
parent2485f1725614cab0d15bef3738ad89cf1b6e91a4 (diff)
gnu: emacs-closql: Update to 1.0.0-1.70b98db.
* gnu/packages/emacs-xyz.scm (emacs-closql): Update to 1.0.0-1.70b98db.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm44
1 files changed, 23 insertions, 21 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a2e09bead9..060259e2e1 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -11503,31 +11503,33 @@ object @code{nil} corresponds 1:1 with @code{NULL} in the database.")
(license license:gpl3+)))
(define-public emacs-closql
- (package
- (name "emacs-closql")
- (version "1.0.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/emacscollective/closql.git")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1xhpfjjkjqfc1k2rj77cscclz5r7gpvv3hi202x178vdcpipjwar"))))
- (build-system emacs-build-system)
- (propagated-inputs
- `(("emacs-emacsql" ,emacs-emacsql)))
- (home-page "https://github.com/emacscollective/closql")
- (synopsis "Store EIEIO objects using EmacSQL")
- (description
- "This package allows to store uniform EIEIO objects in an EmacSQL
+ ;; Take a commit newer than 1.0.0 release because of Emacs upgrade to 26.3.
+ (let ((commit "70b98dbae53611d10a461d9b4a6f71086910dcef"))
+ (package
+ (name "emacs-closql")
+ (version (git-version "1.0.0" "1" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emacscollective/closql.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1wvhrihg663f61yzc7f0vha2abjdnlwbk0gjcwakdfk1bhwf5ikh"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-emacsql" ,emacs-emacsql)))
+ (home-page "https://github.com/emacscollective/closql")
+ (synopsis "Store EIEIO objects using EmacSQL")
+ (description
+ "This package allows to store uniform EIEIO objects in an EmacSQL
database. SQLite is used as backend. This library imposes some restrictions
on what kind of objects can be stored; it isn't intended to store arbitrary
objects. All objects have to share a common superclass and subclasses cannot
add any additional instance slots.")
- (license license:gpl3)))
+ (license license:gpl3))))
(define-public emacs-epkg
;; The release version is to old for the current database scheme.