summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-10-29 15:43:21 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-10-30 17:47:54 +0100
commitbd0b4379b248dc7e08e152d3f597a2bbee81b4b3 (patch)
treebd752c4f26fc8c4beb83c55a34bb93c1ce9fde93 /gnu/packages
parent8a637e79ed6410f093a040f788708b2cf8678bbf (diff)
gnu: openblas: Make substitutable on MIPS.
* gnu/packages/maths.scm (openblas)[arguments]: Make package substitutable when the system is MIPS.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/maths.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index b5abc48b36..b4b930de47 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1474,13 +1474,14 @@ constant parts of it.")
(build-system gnu-build-system)
(arguments
`(#:tests? #f ;no "check" target
- ;; DYNAMIC_ARCH is only supported on x86. When it is disabled,
- ;; OpenBLAS will tune itself to the build host, so we need to disable
- ;; substitutions.
+ ;; DYNAMIC_ARCH is only supported on x86. When it is disabled and no
+ ;; TARGET is specified, OpenBLAS will tune itself to the build host, so
+ ;; we need to disable substitutions.
#:substitutable?
,(let ((system (or (%current-target-system) (%current-system))))
(or (string-prefix? "x86_64" system)
- (string-prefix? "i686" system)))
+ (string-prefix? "i686" system)
+ (string-prefix? "mips" system)))
#:make-flags
(list (string-append "PREFIX=" (assoc-ref %outputs "out"))
"SHELL=bash"