summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-12-17 11:40:31 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-12-17 11:40:31 +0100
commiteb3c105126beb583f3cfb25ccc48a4e43b7e6042 (patch)
treee12a102f54cb59e55c91420c6093e981e0d47de7 /gnu/packages
parente7fa79fd91f00e66ecbebef4d9f0991c21238ab8 (diff)
gnu: r-deconstructsigs: Move from "annotation" to "package" section.
* gnu/packages/bioconductor.scm (r-deconstructsigs): Move variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioconductor.scm56
1 files changed, 28 insertions, 28 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index bdedeabede..befc2a9420 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -748,34 +748,6 @@ annotations.")
"This is a manifest package for Illumina's EPIC methylation arrays.")
(license license:artistic2.0)))
-;; This is a CRAN package, but it depends on r-bsgenome-hsapiens-ucsc-hg19
-;; from Bioconductor.
-(define-public r-deconstructsigs
- (package
- (name "r-deconstructsigs")
- (version "1.8.0")
- (source (origin
- (method url-fetch)
- (uri (cran-uri "deconstructSigs" version))
- (sha256
- (base32
- "014x0nb23jb98666kaav2phkvmkr38pi38jv0dqd4jv7zp0gdf1a"))))
- (properties
- `((upstream-name . "deconstructSigs")))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-bsgenome" ,r-bsgenome)
- ("r-bsgenome-hsapiens-ucsc-hg19" ,r-bsgenome-hsapiens-ucsc-hg19)
- ("r-genomeinfodb" ,r-genomeinfodb)
- ("r-reshape2" ,r-reshape2)))
- (home-page "https://github.com/raerose01/deconstructSigs")
- (synopsis "Identifies signatures present in a tumor sample")
- (description "This package takes sample information in the form of the
-fraction of mutations in each of 96 trinucleotide contexts and identifies
-the weighted combination of published signatures that, when summed, most
-closely reconstructs the mutational profile.")
- (license license:gpl2+)))
-
;; This is a CRAN package, but it depends on Bioconductor packages.
(define-public r-nmf
(package
@@ -1289,6 +1261,34 @@ and evaluate clustering results.")
arbitrary genomic intervals along chromosomal ideogram.")
(license license:gpl2)))
+;; This is a CRAN package, but it depends on r-bsgenome-hsapiens-ucsc-hg19
+;; from Bioconductor.
+(define-public r-deconstructsigs
+ (package
+ (name "r-deconstructsigs")
+ (version "1.8.0")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "deconstructSigs" version))
+ (sha256
+ (base32
+ "014x0nb23jb98666kaav2phkvmkr38pi38jv0dqd4jv7zp0gdf1a"))))
+ (properties
+ `((upstream-name . "deconstructSigs")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-bsgenome" ,r-bsgenome)
+ ("r-bsgenome-hsapiens-ucsc-hg19" ,r-bsgenome-hsapiens-ucsc-hg19)
+ ("r-genomeinfodb" ,r-genomeinfodb)
+ ("r-reshape2" ,r-reshape2)))
+ (home-page "https://github.com/raerose01/deconstructSigs")
+ (synopsis "Identifies signatures present in a tumor sample")
+ (description "This package takes sample information in the form of the
+fraction of mutations in each of 96 trinucleotide contexts and identifies
+the weighted combination of published signatures that, when summed, most
+closely reconstructs the mutational profile.")
+ (license license:gpl2+)))
+
(define-public r-affycomp
(package
(name "r-affycomp")