summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-02-07 14:01:45 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-02-07 14:26:57 +0200
commitce6c13ee8c90fdfd3d17e69a3be36db1c3c16215 (patch)
tree3151eb276838f79315de13f5323ee69f56792611 /gnu/packages
parentb39b33e8c8e4c42d80615a0f4cd6dcac83033c92 (diff)
gnu: python-cryptography: Update to 1.2.2.
* gnu/packages/python.scm (python-cryptography): Update to 1.2.2. [source]: Change to `pypi uri` syntax. [native-inputs]: Add python-pyasn1, python-pyasn1-modules, python-hypothesis. (python2-cryptography)[propagated-inputs]: Add python2-backport-ssl-match-hostname
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index ae7917edda..f8d82a6316 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5799,15 +5799,14 @@ responses, rather than doing any computation.")
(define-public python-cryptography
(package
(name "python-cryptography")
- (version "1.0.2")
+ (version "1.2.2")
(source
(origin
(method url-fetch)
- (uri (string-append "https://pypi.python.org/packages/source/c/"
- "cryptography/cryptography-" version ".tar.gz"))
+ (uri (pypi-uri "cryptography" version))
(sha256
(base32
- "1jmcidddbbgdavvnvjjc0pda4b9a5i9idsivchn69pqxx68x8k6n"))))
+ "0rvaha7ymgbqkzbxk7xmj67k5b3hbp8w8cn3m5z776vd22wrq89z"))))
(build-system python-build-system)
(inputs
`(("openssl" ,openssl)))
@@ -5820,8 +5819,11 @@ responses, rather than doing any computation.")
("python-iso8601" ,python-iso8601)))
(native-inputs
`(("python-cryptography-vectors" ,python-cryptography-vectors)
+ ("python-hypothesis" ,python-hypothesis)
("python-setuptools" ,python-setuptools)
("python-pretend" ,python-pretend)
+ ("python-pyasn1" ,python-pyasn1)
+ ("python-pyasn1-modules" ,python-pyasn1-modules)
("python-pytest" ,python-pytest)))
(home-page "https://github.com/pyca/cryptography")
(synopsis "Cryptographic recipes and primitives for Python")
@@ -5839,6 +5841,8 @@ message digests and key derivation functions.")
(package (inherit crypto)
(propagated-inputs
`(("python2-ipaddress" ,python2-ipaddress)
+ ("python2-backport-ssl-match-hostname"
+ ,python2-backport-ssl-match-hostname)
,@(package-propagated-inputs crypto))))))
(define-public python-pyopenssl