summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-02-07 15:24:43 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-02-07 15:24:43 +0200
commitf2d06d4697bf41d88d99269d1198b95f43af4617 (patch)
tree5903a6b44d42cbe9fb2c77b109ae5cb1c378e184 /gnu/packages
parentce6c13ee8c90fdfd3d17e69a3be36db1c3c16215 (diff)
gnu: python2-backport-ssl-match-hostname: Update to 3.5.0.1.
* gnu/packages/python.scm (python2-backport-ssl-match-hostname): Update to 3.5.0.1. [arguments]: Skip tests. [synopsis]: Update for python version 3.5.x.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index f8d82a6316..e2298a041a 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -627,7 +627,7 @@ etc. ")
(define-public python2-backport-ssl-match-hostname
(package
(name "python2-backport-ssl-match-hostname")
- (version "3.4.0.2")
+ (version "3.5.0.1")
(source
(origin
(method url-fetch)
@@ -637,13 +637,15 @@ etc. ")
version ".tar.gz"))
(sha256
(base32
- "1bnn47ipvhy49n0m50v27lp4xj6sqdkdw676ypd7pawsn1zhwh87"))))
+ "1wndipik52cyqy0677zdgp90i435pmvwd89cz98lm7ri0y3xjajh"))))
(build-system python-build-system)
- (arguments `(#:python ,python-2))
+ (arguments
+ `(#:python ,python-2
+ #:tests? #f)) ; no test target
(inputs
`(("python2-setuptools" ,python2-setuptools)))
- (home-page "https://pypi.python.org/pypi/backports.ssl_match_hostname")
- (synopsis "Backport of ssl.match_hostname() function from Python 3.4")
+ (home-page "https://bitbucket.org/brandon/backports.ssl_match_hostname")
+ (synopsis "Backport of ssl.match_hostname() function from Python 3.5")
(description
"This backport brings the ssl.match_hostname() function to users of
earlier versions of Python. The function checks the hostname in the