summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-09-02 23:30:16 +0200
committerLudovic Courtès <ludo@gnu.org>2016-09-02 23:49:47 +0200
commit241826b5abcfd72abbc9bc8a450c171e0f5d0541 (patch)
treebe5bda48c4df56240d2f97de2f13589ea30db39c /gnu/packages
parent075be8dbe0c40ae2f285da8d2035683937e1377d (diff)
gnu: procps: Disable faulty floating point test.
* gnu/packages/linux.scm (procps)[arguments]: Add 'disable-strtod-test' phase.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/linux.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 6dee46086f..61620abbb4 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -590,6 +590,15 @@ block devices, UUIDs, TTYs, and many other tools.")
(srfi srfi-26))
#:phases
(modify-phases %standard-phases
+ (add-before 'check 'disable-strtod-test
+ (lambda _
+ ;; Disable the 'strtod' test, which fails on 32-bit systems.
+ ;; This is what upstream does:
+ ;; <https://gitlab.com/procps-ng/procps/commit/100afbc1491be388f1429021ff65d969f4b1e08f>.
+ (substitute* "Makefile"
+ (("^(TESTS|check_PROGRAMS) = .*$" all)
+ (string-append "# " all "\n")))
+ #t))
(add-after
'install 'post-install
;; Remove commands and man pages redudant with