summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-09-01 23:06:42 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-09-02 06:44:36 +0300
commit2b031d3fc109c5b726d0711d948ee465f662f0a4 (patch)
tree372e24806ff75022918b122113dc8ab723e0e45d /gnu/packages
parent7e21b9fb2625d3d5050acceea0fe433c48c00d76 (diff)
gnu: python2-scikit-image: Use strip-python2-variant.
* gnu/packages/python.scm (python2-scikit-image): Inherit using strip-python2-variant. [propagated-inputs]: Remove work-around for python2-matplotlib, python2-numpy, python2-scipy.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm12
1 files changed, 5 insertions, 7 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 06de46b859..dd59be8f02 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2919,21 +2919,19 @@ mining and data analysis.")
(synopsis "Image processing in Python")
(description
"Scikit-image is a collection of algorithms for image processing.")
- (license license:bsd-3)))
+ (license license:bsd-3)
+ (properties `((python2-variant . ,(delay python2-scikit-image))))))
(define-public python2-scikit-image
- (let ((scikit-image (package-with-python2 python-scikit-image)))
+ (let ((scikit-image (package-with-python2
+ (strip-python2-variant python-scikit-image))))
(package (inherit scikit-image)
(native-inputs
`(("python2-mock" ,python2-mock)
,@(package-native-inputs scikit-image)))
(propagated-inputs
`(("python2-pytz" ,python2-pytz)
- ("python2-matplotlib" ,python2-matplotlib)
- ("python2-numpy" ,python2-numpy)
- ("python2-scipy" ,python2-scipy)
- ,@(fold alist-delete (package-propagated-inputs scikit-image)
- '("python-matplotlib" "python-numpy" "python-scipy")))))))
+ ,@(package-propagated-inputs scikit-image))))))
(define-public python-redis
(package