summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-11-24 15:24:25 +0100
committerRicardo Wurmus <rekado@elephly.net>2016-11-28 22:43:17 +0100
commit2d9fb1702fb0d142e83cfbf949f9330981ed9687 (patch)
tree0fea5c47cf2b1bac0a20cfe45042b8548a0a6df2 /gnu/packages
parentc827f2028629c43f73aee99600d34fc97fca4208 (diff)
gnu: Add r-seqgl.
* gnu/packages/bioinformatics.scm (r-seqgl): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioinformatics.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 73e1d09b89..5f63707bf8 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7613,6 +7613,36 @@ must be built and this dictionary can be used for determining kernels for DNA
Sequences.")
(license license:gpl2+))))
+(define-public r-seqgl
+ (package
+ (name "r-seqgl")
+ (version "1.1.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/ManuSetty/SeqGL/"
+ "archive/" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0pnk1p3sci5yipyc8xnb6jbmydpl80fld927xgnbcv104hy8h8yh"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biostrings" ,r-biostrings)
+ ("r-chipkernels" ,r-chipkernels)
+ ("r-genomicranges" ,r-genomicranges)
+ ("r-spams" ,r-spams)
+ ("r-wgcna" ,r-wgcna)
+ ("r-fastcluster" ,r-fastcluster)))
+ (home-page "https://github.com/ManuSetty/SeqGL")
+ (synopsis "Group lasso for Dnase/ChIP-seq data")
+ (description "SeqGL is a group lasso based algorithm to extract
+transcription factor sequence signals from ChIP, DNase and ATAC-seq profiles.
+This package presents a method which uses group lasso to discriminate between
+bound and non bound genomic regions to accurately identify transcription
+factors bound at the specific regions.")
+ (license license:gpl2+)))
+
(define-public emboss
(package
(name "emboss")