summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2016-11-27 13:11:46 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-11-28 09:00:41 +1000
commit9926875572cf2936b7f23fb291328bfa68c038c6 (patch)
tree01af5ef45b62b6f07dcf9270f7bf424dc01353df /gnu/packages
parentaa28ecc40af91d7cdff2fb3ab4ad86ad10d43ab7 (diff)
gnu: Add newick-utils.
* gnu/packages/bioinformatics.scm (newick-utils): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioinformatics.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 8d2cb93c7c..f04acc0a5c 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -50,6 +50,7 @@
#:use-module (gnu packages documentation)
#:use-module (gnu packages datastructures)
#:use-module (gnu packages file)
+ #:use-module (gnu packages flex)
#:use-module (gnu packages gawk)
#:use-module (gnu packages gcc)
#:use-module (gnu packages gd)
@@ -3472,6 +3473,45 @@ program for nucleotide and protein sequences.")
;; License information found in 'muscle -h' and usage.cpp.
(license license:public-domain)))
+(define-public newick-utils
+ ;; There are no recent releases so we package from git.
+ (let ((commit "da121155a977197cab9fbb15953ca1b40b11eb87"))
+ (package
+ (name "newick-utils")
+ (version (string-append "1.6-1." (string-take commit 8)))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tjunier/newick_utils.git")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "1hkw21rq1mwf7xp0rmbb2gqc0i6p11108m69i7mr7xcjl268pxnb"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'autoconf
+ (lambda _ (zero? (system* "autoreconf" "-vif")))))))
+ (inputs
+ ;; XXX: TODO: Enable Lua and Guile bindings.
+ ;; https://github.com/tjunier/newick_utils/issues/13
+ `(("libxml2" ,libxml2)
+ ("flex" ,flex)
+ ("bison" ,bison)))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)))
+ (synopsis "Programs for working with newick format phylogenetic trees")
+ (description
+ "Newick-utils is a suite of utilities for processing phylogenetic trees
+in Newick format. Functions include re-rooting, extracting subtrees,
+trimming, pruning, condensing, drawing (ASCII graphics or SVG).")
+ (home-page "https://github.com/tjunier/newick_utils")
+ (license license:bsd-3))))
+
(define-public orfm
(package
(name "orfm")