summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-11-24 14:57:06 +0100
committerRicardo Wurmus <rekado@elephly.net>2016-11-28 22:43:16 +0100
commit9f5435d96391cd8438ba6ce6142b20753360b025 (patch)
tree230e87dcfb99947d656199eb651fa14654979262 /gnu/packages
parentd427e03eee99461ade0df4837bc2e7c20c397f10 (diff)
gnu: Add r-googlesheets.
* gnu/packages/statistics.scm (r-googlesheets): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/statistics.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index cec304db66..0ba33165d6 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -3314,6 +3314,34 @@ character vector.")
@code{A1:D10} style of cell range specification.")
(license license:expat)))
+(define-public r-googlesheets
+ (package
+ (name "r-googlesheets")
+ (version "0.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "googlesheets" version))
+ (sha256
+ (base32
+ "0ps13h1cv7fj5dh8s4nvwi64wnnyqdsadcaa4iizq1c5s615cwk3"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-cellranger" ,r-cellranger)
+ ("r-dplyr" ,r-dplyr)
+ ("r-httr" ,r-httr)
+ ("r-jsonlite" ,r-jsonlite)
+ ("r-purrr" ,r-purrr)
+ ("r-readr" ,r-readr)
+ ("r-stringr" ,r-stringr)
+ ("r-tidyr" ,r-tidyr)
+ ("r-xml2" ,r-xml2)))
+ (home-page "https://github.com/jennybc/googlesheets")
+ (synopsis "Manage Google spreadsheets from R")
+ (description "This package provides tools to interact with Google Sheets
+from within R.")
+ (license license:expat)))
+
(define-public r-rpart
(package
(name "r-rpart")