summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-03-20 15:27:44 +0100
committerLudovic Courtès <ludo@gnu.org>2016-03-20 15:27:44 +0100
commite71ef7adaece7e132a5059139122b45083ea1b39 (patch)
tree24805ba5c5dba0837e421f4d265ddf55a2b74239 /gnu/packages
parent0bd3597bbe0acb901f63ef386489eebb8e177c1c (diff)
system: Make sure fonts are searched for in the system profile.
This fixes a bug whereby fonts in /run/current-system/profile would be invisible to Fontconfig. * gnu/packages/fontutils.scm (fontconfig): Add comment about system profile not being searched. * gnu/system/shadow.scm (default-skeletons)[fonts.conf-content, fonts.conf]: New variable. Add FONTS.CONF to the skeletons.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/fontutils.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 01a0ee7c36..7e3f293817 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -94,8 +94,12 @@ anti-aliased glyph bitmap generation with 256 gray levels.")
(string-append "--with-default-fonts="
(assoc-ref %build-inputs "gs-fonts")
"/share/fonts")
+
;; register fonts from user profile
+ ;; TODO: Add /run/current-system/profile/share/fonts and remove
+ ;; the skeleton that works around it from 'default-skeletons'.
"--with-add-fonts=~/.guix-profile/share/fonts"
+
;; python is not actually needed
"PYTHON=false")
#:phases