summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-07-18 22:14:09 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-07-20 22:19:34 +0200
commit19d311b4f2e2dc2a5e97bec8d48c23abe1896851 (patch)
treea2b3d96ab2a7a55bef9af43d47b19bf6037bdefe /gnu/packages
parentab84b927efa44cd3e81568db4c775f6ab7e3c344 (diff)
gnu: Add allegro.
* gnu/packages/game-development.scm (allegro): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/game-development.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index b11285ab54..03623aaa89 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2015, 2016 David Thompson <davet@gnu.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
+;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -342,6 +343,46 @@ etc.")
(home-page "http://liballeg.org")
(license license:giftware)))
+(define-public allegro
+ (package
+ (name "allegro")
+ (version "5.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://download.gna.org/allegro/allegro/"
+ version "/allegro-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1mwzgzc4nb5k5zkbq7yrc6hg63yxq3wk69lmjag1h19x8b6njnmg"))))
+ (build-system cmake-build-system)
+ (arguments `(#:tests? #f)) ; there are no tests
+ (inputs
+ ;; FIXME: Add the following optional inputs: xinput2, opensl, dumb
+ `(("flac" ,flac)
+ ("freetype" ,freetype)
+ ("glu" ,glu)
+ ("gtk" ,gtk+-2)
+ ("libjpeg" ,libjpeg)
+ ("libpng" ,libpng)
+ ("libtheora" ,libtheora)
+ ("libvorbis" ,libvorbis)
+ ("libxcursor" ,libxcursor)
+ ("libxinerama" ,libxinerama)
+ ("libxrandr" ,libxrandr)
+ ("mesa" ,mesa)
+ ("openal" ,openal)
+ ("physfs" ,physfs)
+ ("zlib" ,zlib)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (synopsis "Game programming library")
+ (description "Allegro is a library mainly aimed at video game and
+multimedia programming. It handles common, low-level tasks such as creating
+windows, accepting user input, loading data, drawing images, playing sounds,
+etc.")
+ (home-page "http://liballeg.org")
+ (license license:bsd-3)))
+
(define-public aseprite
(package
(name "aseprite")