summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-10-04 10:17:56 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-10-04 10:21:38 +0200
commitc5d17d50d00a737870b5faa54fb6fc2f17dacb1a (patch)
treeabdf141acf9794beaf218284392d7e89522299b7 /gnu/packages
parent5c31e981bbed2c1e4528274363723a230b9f21f9 (diff)
gnu: warzone2100: Update to 3.2.1.
* gnu/packages/games.scm (warzone2100): Update to 3.2.1. [arguments]: Remove phase "set-sdl-paths", add phase "link-tests-with-qt", add phase "remove-reference-to-missing-file". [inputs]: Replace "qt-4" with "qt", replace "sdl-union" with "sdl2", add "openssl".
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/games.scm29
1 files changed, 18 insertions, 11 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 71157d6bb8..b6ff1b78cf 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2409,7 +2409,7 @@ capture it and get out alive?")
(define-public warzone2100
(package
(name "warzone2100")
- (version "3.1.5")
+ (version "3.2.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/" name
@@ -2417,16 +2417,22 @@ capture it and get out alive?")
".tar.xz"))
(sha256
(base32
- "0hm49i2knvvg3wlnryv7h4m84s3qa7jfyym5yy6365sx8wzcrai1"))))
+ "1nd609s0g4sya3r4amhkz3f4dpdmm94vsd2ii76ap665a1nbfrhg"))))
(build-system gnu-build-system)
(arguments
- `(#:phases (modify-phases %standard-phases
- (add-after 'set-paths 'set-sdl-paths
- (lambda* (#:key inputs #:allow-other-keys)
- (setenv "CPATH"
- (string-append (assoc-ref inputs "sdl-union")
- "/include/SDL"))
- #t)))))
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'link-tests-with-qt
+ (lambda _
+ (substitute* "tests/Makefile.in"
+ (("(framework_linktest_LDADD|maptest_LDADD) = " prefix)
+ (string-append prefix "$(QT5_LIBS) ")))
+ #t))
+ (add-after 'unpack 'remove-reference-to-missing-file
+ (lambda _
+ (substitute* "icons/Makefile.in"
+ (("\\$\\(INSTALL_DATA\\) \\$\\(srcdir\\)/warzone2100.appdata.xml.*") ""))
+ #t)))))
(native-inputs `(("pkg-config" ,pkg-config)
("unzip" ,unzip)
("zip" ,zip)))
@@ -2439,9 +2445,10 @@ capture it and get out alive?")
("libxrandr" ,libxrandr)
("openal" ,openal)
("physfs" ,physfs)
- ("qt", qt-4)
+ ("qt" ,qt)
+ ("openssl" ,openssl)
("quesoglc" ,quesoglc)
- ("sdl-union" ,(sdl-union))))
+ ("sdl2" ,sdl2)))
(home-page "http://wz2100.net")
(synopsis "3D Real-time strategy and real-time tactics game")
(description