summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2016-12-31 12:42:10 +0100
committerDavid Craven <david@craven.ch>2017-01-04 16:03:16 +0100
commite0ddaa8be3fad4efbe3c8be8dfb8dc63a784f335 (patch)
tree22eabb4013107e902125c2b015ffb22cfc9b8fcb /gnu/packages
parent2b1f7b83f7e19dc3f2e637147148f9e95fca8921 (diff)
gnu: camlp4: Compile native version.
* gnu/packages/ocaml.scm (camlp4)[arguments]: Disable parallel-build. Change default target to "all" to compile native and byte version. Signed-off-by: David Craven <david@craven.ch>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ocaml.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index efe58c542e..35c782473c 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -238,6 +238,10 @@ Git-friendly development workflow.")
(inputs `(("ocaml" ,ocaml)))
(arguments
'(#:tests? #f ;no documented test target
+ ;; a race-condition will lead byte and native targets to mkdir _build
+ ;; which fails on the second attempt.
+ #:parallel-build? #f
+ #:make-flags '("all")
#:phases (modify-phases %standard-phases
(replace
'configure