summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-10-05 22:27:23 +0200
committerLudovic Courtès <ludo@gnu.org>2015-10-05 22:34:34 +0200
commitf211b2af676751b66d1443e5371b92c9a98c8a0c (patch)
treed138f84eff1a0477e99bf59748669b9449089d39 /gnu/packages
parent2ebe938c2f943232955df889a72a6280c412a649 (diff)
Revert "gnu: glibc: Honor 'GUIX_LOCPATH'."
This reverts commits fbb909ac7e947ebc8aea2c2efca7df3a78dfc3c4 and 2ebe938c2f943232955df889a72a6280c412a649.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/base.scm8
-rw-r--r--gnu/packages/patches/glibc-guix-locpath.patch34
2 files changed, 2 insertions, 40 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index c6abf56ebf..1250f51108 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -484,7 +484,6 @@ store.")
(patches (map search-patch
'("glibc-ldd-x86_64.patch"
"glibc-locale-incompatibility.patch"
- "glibc-guix-locpath.patch"
"glibc-o-largefile.patch")))))
(build-system gnu-build-system)
@@ -615,13 +614,10 @@ store.")
(native-search-paths
;; Search path for packages that provide locale data. This is useful
- ;; primarily in build environments. Use 'GUIX_LOCPATH' rather than
- ;; 'LOCPATH' to avoid interference with the host system's libc on foreign
- ;; distros.
+ ;; primarily in build environments.
(list (search-path-specification
(variable "GUIX_LOCPATH")
- (files (list (string-append "lib/locale/" version)
- "lib/locale")))))
+ (files '("lib/locale")))))
(synopsis "The GNU C Library")
(description
diff --git a/gnu/packages/patches/glibc-guix-locpath.patch b/gnu/packages/patches/glibc-guix-locpath.patch
deleted file mode 100644
index 69bb2e50de..0000000000
--- a/gnu/packages/patches/glibc-guix-locpath.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-Honor a special 'GUIX_LOCPATH' environment variable.
-
-This is most useful when using Guix on top of another distro, which uses an
-different libc version with incompatible locale data. In this case, setting
-'GUIX_LOCPATH' rather than 'LOCPATH' allows users to tell Guix's libc where to
-look for its locale data without breaking programs that use the other libc.
-
-See <https://lists.gnu.org/archive/html/guix-devel/2015-09/msg00717.html> for
-some background information.
-
---- a/locale/newlocale.c
-+++ b/locale/newlocale.c
-@@ -103,6 +103,8 @@ __newlocale (int category_mask, const char *locale, __locale_t base)
- locale_path_len = 0;
-
- locpath_var = getenv ("LOCPATH");
-+ if (locpath_var == NULL || locpath_var[0] == '\0')
-+ locpath_var = getenv ("GUIX_LOCPATH");
- if (locpath_var != NULL && locpath_var[0] != '\0')
- {
- if (__argz_create_sep (locpath_var, ':',
-diff --git a/locale/setlocale.c b/locale/setlocale.c
-index ead030d..0e66c7b 100644
---- a/locale/setlocale.c
-+++ b/locale/setlocale.c
-@@ -252,6 +252,8 @@ setlocale (int category, const char *locale)
- locale_path_len = 0;
-
- locpath_var = getenv ("LOCPATH");
-+ if (locpath_var == NULL || locpath_var[0] == '\0')
-+ locpath_var = getenv ("GUIX_LOCPATH");
- if (locpath_var != NULL && locpath_var[0] != '\0')
- {
- if (__argz_create_sep (locpath_var, ':',