summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-08-15 11:46:49 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-08-16 17:04:12 +0200
commit178bd68116a0720c5b990fea1af770630844f297 (patch)
tree999da97211f58086d64f8d8c3e50dfb46e356e5e /gnu/packages
parent376a6df4a5a2e18eade9341c6d3c54707f1d8d0a (diff)
gnu: ghc-vector-algorithms: Fix build errors.
* gnu/packages/haskell.scm (ghc-vector-algorithms)[arguments]: Allow build with newer version of vector; add phase to disable building of broken QuickCheck tests.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/haskell.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 5efce7388d..577ecb8a0e 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -8307,6 +8307,17 @@ between 2 and 3 times faster than the Mersenne Twister.")
(base32
"0w4hf598lpxfg58rnimcqxrbnpqq2jmpjx82qa5md3q6r90hlipd"))))
(build-system haskell-build-system)
+ ;; The limits have been adjusted in a revision of the cabal file.
+ (arguments
+ '(#:configure-flags (list "--allow-newer=vector")
+ #:phases
+ (modify-phases %standard-phases
+ ;; The tests cannot be built due to type errors.
+ (add-after 'unpack 'do-not-build-quickcheck-tests
+ (lambda _
+ (substitute* "vector-algorithms.cabal"
+ (("\\!flag\\(properties\\)") "True"))
+ #t)))))
(inputs
`(("ghc-vector" ,ghc-vector)
("ghc-mtl" ,ghc-mtl)