summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2018-12-20 20:28:07 -0600
committerEric Bavier <bavier@member.fsf.org>2018-12-20 23:20:25 -0600
commit18ebaa9eeb01e3a2f9963281d5dc5e3866d40ea4 (patch)
tree5535d8794f6e814b78abde52e98baa21cea2085f /gnu/packages
parent8aedb3ad8ac9052824bd5d7acce7e5ca4abf28be (diff)
gnu: Add libmanette.
* gnu/packages/games.scm (libmanette): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/games.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 55817dc753..cff717b233 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -149,6 +149,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system go)
#:use-module (guix build-system haskell)
+ #:use-module (guix build-system meson)
#:use-module (guix build-system python)
#:use-module (guix build-system cmake)
#:use-module (guix build-system trivial))
@@ -5874,3 +5875,32 @@ libraries. AIFF sound effects and music in MOD and OGG formats are supported
when packaged in Blorb container files or optionally from individual files.")
(home-page "http://frotz.sourceforge.net")
(license license:gpl2+))))
+
+(define-public libmanette
+ (package
+ (name "libmanette")
+ (version "0.2.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "14vqz30p4693yy3yxs0gj858x25sl2kawib1g9lj8g5frgl0hd82"))))
+ (build-system meson-build-system)
+ (native-inputs
+ `(("glib" ,glib "bin") ; for glib-compile-resources
+ ("gobject-introspection" ,gobject-introspection)
+ ("pkg-config" ,pkg-config)
+ ("vala" ,vala)))
+ (inputs
+ `(("libevdev" ,libevdev)
+ ("libgudev" ,libgudev)))
+ (home-page "https://wiki.gnome.org/Apps/Games")
+ (synopsis "Game controller library")
+ (description "Libmanette is a small GObject library giving you simple
+access to game controllers. It supports the de-facto standard gamepads as
+defined by the W3C standard Gamepad specification or as implemented by the SDL
+GameController.")
+ (license license:lgpl2.1+)))