summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-08-15 12:14:53 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-08-16 17:04:12 +0200
commit19395aec69b5e62f5de8e9edeb7ad8edbb6e9a5b (patch)
tree4430cdec544363de71efc5dd85586c73ad1a1082 /gnu/packages
parent7e2c8cb5fc82ad7c881ca134fb803a5d3f57c0c2 (diff)
gnu: Add ghc-errorcall-eq-instance.
* gnu/packages/haskell.scm (ghc-errorcall-eq-instance): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/haskell.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index bee9e6eefc..569961defc 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -9849,4 +9849,31 @@ disk space usage.")
(description "This package provides a library implementing the XDG Base Directory spec.")
(license license:bsd-3)))
+(define-public ghc-errorcall-eq-instance
+ (package
+ (name "ghc-errorcall-eq-instance")
+ (version "0.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "errorcall-eq-instance/errorcall-eq-instance-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0hqw82m8bbrxy5vgdwb83bhzdx070ibqrm9rshyja7cb808ahijm"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-base-orphans" ,ghc-base-orphans)))
+ (native-inputs
+ `(("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-hspec" ,ghc-hspec)
+ ("hspec-discover" ,hspec-discover)))
+ (home-page "http://hackage.haskell.org/package/errorcall-eq-instance")
+ (synopsis "Orphan Eq instance for ErrorCall")
+ (description
+ "Prior to @code{base-4.7.0.0} there was no @code{Eq} instance for @code{ErrorCall}.
+This package provides an orphan instance.")
+ (license license:expat)))
+
;;; haskell.scm ends here