summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-08-15 11:31:19 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-08-16 17:04:12 +0200
commit5cb462004328de14f3bf2ffa5f274ccd53fc6208 (patch)
tree82f0258317e25c9aa04f98cf3c15413a932a2940 /gnu/packages
parentc106c48ee70fe91176fcfa249916818da17c2984 (diff)
gnu: ghc-conduit: Update to 1.3.0.3.
* gnu/packages/haskell.scm (ghc-conduit): Update to 1.3.0.3. [inputs]: Add ghc-mono-traversable, ghc-silently, ghc-unliftio, ghc-unliftio-core, and ghc-vector.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/haskell.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index e94b15b570..bc49adddf8 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5640,22 +5640,27 @@ template-haskell abstract syntax.")
(define-public ghc-conduit
(package
(name "ghc-conduit")
- (version "1.2.12.1")
+ (version "1.3.0.3")
(source (origin
(method url-fetch)
(uri (string-append "https://hackage.haskell.org/package/"
"conduit/conduit-" version ".tar.gz"))
(sha256
(base32
- "0zl6gflh7y36y2vypjhqx13nhkk5y3h12c1zj7kjfclrmwnvnwh0"))))
+ "1sangm0qqi9dzlq95746a3kl14k8b09592a423shxjf2a0b1yx5v"))))
(build-system haskell-build-system)
(inputs
`(("ghc-exceptions" ,ghc-exceptions)
("ghc-lifted-base" ,ghc-lifted-base)
+ ("ghc-mono-traversable" ,ghc-mono-traversable)
("ghc-mmorph" ,ghc-mmorph)
("ghc-mtl" ,ghc-mtl)
("ghc-resourcet" ,ghc-resourcet)
+ ("ghc-silently" ,ghc-silently)
("ghc-transformers-base" ,ghc-transformers-base)
+ ("ghc-unliftio" ,ghc-unliftio)
+ ("ghc-unliftio-core" ,ghc-unliftio-core)
+ ("ghc-vector" ,ghc-vector)
("ghc-void" ,ghc-void)))
(native-inputs
`(("ghc-quickcheck" ,ghc-quickcheck)