summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-08-15 11:30:54 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-08-16 17:04:11 +0200
commitd5040b44199edc7c5a8371578112fe346257b9a3 (patch)
tree2d061d5175119ad0d32fd8cb6babe54b52aac088 /gnu/packages
parent74b30be0273b9692ee24292e75d13f125e1dbdf2 (diff)
gnu: Add ghc-typed-process.
* gnu/packages/haskell.scm (ghc-typed-process): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/haskell.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 82baa82fd5..65bd597c21 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -6404,6 +6404,36 @@ dependency that depends on a large C library, and @code{rfc5051} might be
better for some purposes.")
(license license:bsd-3)))
+(define-public ghc-typed-process
+ (package
+ (name "ghc-typed-process")
+ (version "0.2.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "typed-process/typed-process-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0c6gvgvjyncbni9a5bvpbglknd4yclr3d3hfg9bhgahmkj40dva2"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-async" ,ghc-async)
+ ("ghc-stm" ,ghc-stm)))
+ (native-inputs
+ `(("ghc-base64-bytestring" ,ghc-base64-bytestring)
+ ("ghc-hspec" ,ghc-hspec)
+ ("hspec-discover" ,hspec-discover)
+ ("ghc-temporary" ,ghc-temporary)))
+ (home-page "https://haskell-lang.org/library/typed-process")
+ (synopsis "Run external processes with strong typing of streams")
+ (description
+ "This library provides the ability to launch and interact with external
+processes. It wraps around the @code{process} library, and intends to improve
+upon it.")
+ (license license:expat)))
+
(define-public ghc-conduit-extra
(package
(name "ghc-conduit-extra")