summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-08-15 11:25:25 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-08-16 17:04:11 +0200
commite42e9024c1528deca9daa86482ac1a5c322e5cd2 (patch)
tree83cb356771c08e163276f76e5a05ecbe858d5f15 /gnu/packages
parent828c9ff83180efe4a8d894738c38360f45552e81 (diff)
gnu: Add ghc-call-stack-boot.
* gnu/packages/haskell.scm (ghc-call-stack-boot): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/haskell.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index b3aff4b12a..b53ab280e8 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -4455,6 +4455,14 @@ forms of the Yoneda lemma, and (co)density (co)monads for Haskell.")
call stacks with different versions of the compiler.")
(license license:expat)))
+;; This is used as an input to ghc-hunit. We cannot use ghc-call-stack there,
+;; because it depends on ghc-nanospec, which depends on ghc-hunit.
+(define-public ghc-call-stack-boot
+ (package
+ (inherit ghc-call-stack)
+ (arguments '(#:tests? #f))
+ (inputs '())))
+
(define-public ghc-statevar
(package
(name "ghc-statevar")