summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-06-12 20:37:40 +0200
committerDavid Craven <david@craven.ch>2016-08-13 14:07:46 +0200
commitf90b81a5f08219592b863dfb6e769a9ce9496dc6 (patch)
treebdc231aba243a0537771314d5e79504e682d1fc6 /gnu/packages
parent06a79865efe935c215d8e24bbfafb7413c7afdce (diff)
gnu: kde-frameworks: Add karchive.
* gnu/packages/kde-frameworks.scm (karchive): New variable. Co-authored-by: Hartmut Goebel <h.goebel@crazy-compilers.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/kde-frameworks.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 73ffb54347..d11d9f18cc 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -25,6 +25,7 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix utils)
+ #:use-module (gnu packages compression)
#:use-module (gnu packages glib)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
@@ -211,6 +212,40 @@ documentation.")
;; This list is taken from http://packaging.neon.kde.org/cgit/
(license (list license:bsd-2 license:expat))))
+(define-public karchive
+ (package
+ (name "karchive")
+ (version "5.24.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/frameworks/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1n5nfhrfvqnrdjgjjy7arqik4fya5bp3dvxa16mlhqr19azkavzq"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)))
+ (inputs
+ `(("bzip2" ,bzip2)
+ ("qtbase" ,qtbase)
+ ("xz" ,xz)
+ ("zlib" ,zlib)))
+ (home-page "https://community.kde.org/Frameworks")
+ (synopsis "Qt 5 addon providing access to numerous types of archives")
+ (description "KArchive provides classes for easy reading, creation and
+manipulation of 'archive' formats like ZIP and TAR.
+
+It also provides transparent compression and decompression of data, like the
+GZip format, via a subclass of QIODevice.")
+ ;; The included licenses is are gpl2 and lgpl2.1, but the sources are
+ ;; under a variety of licenses.
+ ;; This list is taken from http://packaging.neon.kde.org/cgit/
+ (license (list license:lgpl2.1 license:lgpl2.1+
+ license:lgpl3+ license:bsd-2))))
+
(define-public kwindowsystem
(package
(name "kwindowsystem")