summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-07-24 16:36:13 +0200
committerLudovic Courtès <ludo@gnu.org>2017-07-24 16:36:13 +0200
commit23212bf9e68d53c18343149eeea9c436ab6f4f52 (patch)
tree2d94b0edd4d4807c1a2c478eb1e8207d364a5729 /gnu/packages
parente2f24597a9da51ba6739f4fdb44217b41a8bab84 (diff)
gnu: perl: Work around "dotless @INC" build issues.
* gnu/packages/perl.scm (perl-task-weaken)[arguments]: New field. (perl-unicode-normalize): Likewise. * gnu/packages/web.scm (perl-http-server-simple)[arguments]: Add #:phases.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/perl.scm20
-rw-r--r--gnu/packages/web.scm11
2 files changed, 29 insertions, 2 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 6bf82eb61a..d9f5fe1377 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015, 2016 Eric Bavier <bavier@member.fsf.org>
@@ -6161,6 +6161,15 @@ of a system.")
(base32
"1i7kd9v8fjsqyhr4rx4a1jv7n5vfjjm1v4agb24pizh0b72p3qk7"))))
(build-system perl-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-before 'configure 'set-search-path
+ (lambda _
+ ;; Work around "dotless @INC" build failure.
+ (setenv "PERL5LIB"
+ (string-append (getcwd) ":"
+ (getenv "PERL5LIB")))
+ #t)))))
(home-page "http://search.cpan.org/dist/Task-Weaken")
(synopsis "Ensure that a platform has weaken support")
(description "One recurring problem in modules that use Scalar::Util's
@@ -7722,6 +7731,15 @@ common serialisation formats such as JSON or CBOR.")
(base32
"0v04bcyjfcfap4kfpc8q3ikq3j7s68nym4ckw3iasmmksdskmcq0"))))
(build-system perl-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-before 'configure 'set-search-path
+ (lambda _
+ ;; Work around "dotless @INC" build failure.
+ (setenv "PERL5LIB"
+ (string-append (getcwd) ":"
+ (getenv "PERL5LIB")))
+ #t)))))
(home-page "http://search.cpan.org/dist/Unicode-Normalize")
(synopsis "Unicode normalization forms")
(description "This Perl module provides Unicode normalization forms.")
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 69a979eaef..e9c5021617 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -2515,7 +2515,16 @@ environment from an HTTP::Request.")
(arguments
;; See the discussion of a related tests issue at
;; https://lists.gnu.org/archive/html/guix-devel/2015-01/msg00346.html
- `(#:tests? #f))
+ `(#:tests? #f
+
+ #:phases (modify-phases %standard-phases
+ (add-before 'configure 'set-search-path
+ (lambda _
+ ;; Work around "dotless @INC" build failure.
+ (setenv "PERL5LIB"
+ (string-append (getcwd) ":"
+ (getenv "PERL5LIB")))
+ #t)))))
(home-page "http://search.cpan.org/dist/HTTP-Server-Simple")
(synopsis "Lightweight HTTP server")
(description "HTTP::Server::Simple is a simple standalone HTTP daemon with