summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-03-26 11:38:14 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-04-03 18:05:11 -0400
commit022a31e0458934d2b4c7ef4f7be3e1d7bcc3aa47 (patch)
tree46d7d98d0bfe01d3c955e42f449cfb403db1a6d5 /gnu/packages
parente5aebf8a599213b719ab633fc177c333f257bb47 (diff)
gnu: dhtnet: Update to 0.0.1-2.024c46f.
* gnu/packages/networking.scm (dhtnet): Update to 0.0.1-2.024c46f. [phases] <delete-problematic-tests>: Reinstate the fileutils test. Disable the new 'tests_ice' tests. Change-Id: I15f7e76cd7a777fc9f537dec752b45f4b5ed4e92
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/networking.scm15
1 files changed, 7 insertions, 8 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 6737779840..146d60031e 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -3986,8 +3986,8 @@ A very simple IM client working over the DHT.
(define-public dhtnet
;; There is no tag nor release; use the latest available commit.
- (let ((revision "1")
- (commit "41848a2c770d7eb0940d731014b81643f85e0d07"))
+ (let ((revision "2")
+ (commit "024c46fb1f14276d4adf15764ed97b733890826e"))
(package
(name "dhtnet")
;; The base version is taken from the CMakeLists.txt file.
@@ -4000,7 +4000,7 @@ A very simple IM client working over the DHT.
(file-name (git-file-name name version))
(sha256
(base32
- "18v2pjrxfrd26p2z27s90marx7b593nz1xwi47lnp2ja7lm1pj4m"))))
+ "191gmfdg22hkmxvzh5i19lr512q4bhgajhlg9mxxgb7jq0842mc6"))))
(outputs (list "out" "debug"))
(build-system cmake-build-system)
(arguments
@@ -4016,11 +4016,10 @@ A very simple IM client working over the DHT.
;; The connectionManager test currently segfaults (see:
;; https://git.jami.net/savoirfairelinux/dhtnet/-/issues/18).
((".*tests_connectionManager.*") "")
- ;; The fileutils test fail, asserting an unexpected returned
- ;; value for the removeAll call when the directory to be
- ;; removed is missing (see:
- ;; https://git.jami.net/savoirfairelinux/dhtnet/-/issues/17).
- ((".*tests_fileutils.*") "")))))))
+ ;; The ICE tests fail inside the containerized build
+ ;; environment, perhaps relying on a name resolver (see:
+ ;; https://git.jami.net/savoirfairelinux/dhtnet/-/issues/25).
+ ((".*tests_ice.*") "")))))))
(native-inputs (list cppunit pkg-config))
;; This library depends on the Jami fork of pjproject that adds ICE
;; support.