summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-10-25 16:05:16 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-10-25 16:58:40 +0200
commit0618aaba01285924181f78e47a796ea6d2f18eb3 (patch)
tree7187f2cef4d0402aa2e0e58487b4dcd0794cb899 /gnu/packages
parent617bca2ab0b4f57c65873cf3858c6387ea775ab1 (diff)
gnu: python-sphinx-gallery: Update to 0.14.0.
* gnu/packages/sphinx.scm (python-sphinx-gallery): Update to 0.14.0. [build-system]: Use pyproject-build-system. [arguments]: Remove custom phases; add custom build phase 'delete-webp-example; move test flags to #:test-flags. [propagated-inputs]: Add python-jupyterlite-sphinx. Change-Id: I58f4b952fe5a2bf942d77813a8a2eeef2e4750b6
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/sphinx.scm46
1 files changed, 27 insertions, 19 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index a7c437d6b4..eee1f1c4a8 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -49,6 +49,7 @@
#:use-module (gnu packages graphviz)
#:use-module (gnu packages image)
#:use-module (gnu packages imagemagick)
+ #:use-module (gnu packages jupyter)
#:use-module (gnu packages python)
#:use-module (gnu packages python-build)
#:use-module (gnu packages python-check)
@@ -528,35 +529,42 @@ Sphinx documentation into your web application. It provides tools to
integrate Sphinx documents in web templates and to handle searches.")
(license license:bsd-3)))
-
(define-public python-sphinx-gallery
(package
(name "python-sphinx-gallery")
- (version "0.10.1")
+ (version "0.14.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "sphinx-gallery" version))
(sha256
- (base32 "1r07sa34511fbnwi2s32q00qdyv5d23d05imyfgnh2ivhfq34gwm"))))
- (build-system python-build-system)
+ (base32 "1hj380d5bjhbzxmhjw8f8b71jy1wk8crad0g3n750m990fphljia"))))
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'writable-files-for-tests
+ (list
+ #:test-flags
+ '(list "--pyargs" "sphinx_gallery" "-k"
+ (string-append
+ ;; These tests require online data.
+ "not test_embed_code_links_get_data"
+ " and not test_run_sphinx"
+ ;; Requires webp support
+ " and not test_image_formats"
+ ;; Needs graphviz
+ " and not test_rebuild"
+ ;; Fails because we've deleted an example file, so the numbers
+ ;; don't match.
+ " and not test_junit"
+ ;; AssertionError.
+ " and not test_embed_links_and_styles"))
+ #:phases
+ '(modify-phases %standard-phases
+ ;; TODO: Our version of matplotlib does not support webp.
+ (add-after 'unpack 'delete-webp-example
(lambda _
- (for-each make-file-writable (find-files "."))))
- (replace 'check
- (lambda* (#:key inputs outputs tests? #:allow-other-keys)
- (when tests?
- (add-installed-pythonpath inputs outputs)
- (invoke "python" "-m" "pytest" "--pyargs" "sphinx_gallery" "-k"
- (string-append
- ;; These tests require online data.
- "not test_embed_code_links_get_data"
- " and not test_run_sphinx"
- ;; AssertionError.
- " and not test_embed_links_and_styles"))))))))
+ (delete-file "sphinx_gallery/tests/tinybuild/examples/plot_webp.py"))))))
+ (propagated-inputs
+ (list python-jupyterlite-sphinx))
(native-inputs
(list python-joblib
python-matplotlib