summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-06 09:34:21 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:10:32 +0200
commit0f2c676ee9257af16fe6128c2930bc7811db14e4 (patch)
treedeebd96f794f2fd4d845bd1cb49d961f4bbfb1b5 /gnu/packages
parent56785dbde3048edcd3ad49b48ae5704612ed4f03 (diff)
gnu: Add texlive-enctex.
* gnu/packages/tex.scm (texlive-enctex): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 507ef8cc94..26fe6d1c64 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4993,6 +4993,26 @@ implementation is output device independent, and made very simple by relying
on @code{everypage}.")
(license license:lppl1.3+)))
+(define-public texlive-enctex
+ (package
+ (name "texlive-enctex")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/generic/enctex/"
+ "tex/generic/enctex/")
+ (base32
+ "1j8ji1ka8vhskm5kn0iwmkhjfp88ly6rva30pr1c9llsmsac5sf2")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/enctex")
+ (synopsis "TeX extension that translates input on its way into TeX")
+ (description
+ "EncTeX is (another) TeX extension, written at the change-file level. It
+provides means of translating input on the way into TeX. It allows, for
+example, translation of multibyte sequences, such as utf-8 encoding.")
+ (license license:gpl3+)))
+
(define-public texlive-environ
(package
(name "texlive-environ")