summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-06 12:01:42 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:10:32 +0200
commit14cd6c2fb4b826869f5f3fa48bbfc581114a6478 (patch)
tree34dc836163e9ee151acb0000a14471929d7430ff /gnu/packages
parent0f2c676ee9257af16fe6128c2930bc7811db14e4 (diff)
gnu: Add texlive-dehyph.
* gnu/packages/tex.scm (texlive-dehyph): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 26fe6d1c64..9c92c99af8 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2769,6 +2769,29 @@ converters, will completely supplant the older patterns.")
(define-deprecated-package texlive-generic-hyph-utf8 texlive-hyph-utf8)
+(define-public texlive-dehyph
+ (package
+ (name "texlive-dehyph")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "tex/generic/dehyph/")
+ (base32
+ "0fkqlsknrlxk8zazcqy4q3nisxr3a4x21aiwqhz8s237rdf3w39g")))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/dehyph")
+ (synopsis "German hyphenation patterns for traditional orthography")
+ (description
+ "The package provides older hyphenation patterns for the German language.
+Please note that by default only pdfLaTeX uses these patterns (mainly for
+backwards compatibility). The older packages ghyphen and gnhyph are now
+bundled together with dehyph, and are no longer be updated. Both XeLaTeX and
+LuaLaTeX use the current German hyphenation patterns taken from Hyphenation
+patterns in UTF-8, and using the Experimental hyphenation patterns for the
+German language package it is possible to make pdfLaTeX use the new German
+patterns as well.")
+ (license license:lppl1.0+)))
+
(define-public texlive-dehyph-exptl
(package
(inherit (simple-texlive-package