summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-04-26 13:32:02 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-04-26 13:33:30 +0200
commit399e1b8e01586c0e8a61bcada2bb5d9a2cbaddc9 (patch)
tree18e8a9ba602675cf2db601068f38d02f18ce2a21 /gnu/packages
parentc22765c933328d04216fe0d8cc7c4868d12dd3fb (diff)
gnu: python-ipykernel: Fix build.
* gnu/packages/python-xyz.scm (python-ipykernel)[build-system]: Use pyproject-build-system. [arguments]: Use pyproject-build-system modules; add build phase 'hide-zmq-deprecation-warnings.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm15
1 files changed, 12 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 937c0be717..2d86cb95df 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9661,17 +9661,26 @@ installing @code{kernelspec}s for use with Jupyter frontends.")
(uri (pypi-uri "ipykernel" version))
(sha256
(base32 "0q5yni8h08nadsn53f957p0pjsjhwl2b2lp1hqz3jn0854z2fa0f"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
(list
- #:imported-modules `(,@%python-build-system-modules
+ #:imported-modules `(,@%pyproject-build-system-modules
(guix build syscalls))
- #:modules '((guix build python-build-system)
+ #:modules '((guix build pyproject-build-system)
(guix build syscalls)
(guix build utils)
(ice-9 match))
#:phases
#~(modify-phases %standard-phases
+ ;; The deprecation warnings break the tests.
+ (add-after 'unpack 'hide-zmq-deprecation-warnings
+ (lambda _
+ (substitute* "pyproject.toml"
+ (("\"ignore:There is no current event loop:DeprecationWarning\"" m)
+ (string-append m ",
+\"ignore:make_current is deprecated.*:DeprecationWarning\",
+\"ignore:zmq.eventloop.ioloop.*:DeprecationWarning\",
+\"ignore:zmq.tests.BaseZMQTestCase.*:DeprecationWarning\"")))))
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?