summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSergio Pastor PĂ©rez <sergio.pastorperez@outlook.es>2023-11-28 22:11:41 +0100
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:56:40 +0200
commit47a4e1e6b876123b6f45cfad28f713e1f34f1cca (patch)
treea3efd29abc9f5c86cd0a1d321bf7affd82bd230f /gnu/packages
parent783c7bb09411ba3b240dee6e19fdaea75a51037a (diff)
gnu: Add rust-gobject-sys-0.18.
* gnu/packages/crates-gtk.scm (rust-gobject-sys-0.18): New variable. (rust-gobject-sys-0.17): Inherit from rust-gobject-sys-0.18. Change-Id: Id5ba73cfa2071c712d4e6a3f8b5f464ce6ed243f Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-gtk.scm40
1 files changed, 30 insertions, 10 deletions
diff --git a/gnu/packages/crates-gtk.scm b/gnu/packages/crates-gtk.scm
index 3f7813a42f..5d535380b3 100644
--- a/gnu/packages/crates-gtk.scm
+++ b/gnu/packages/crates-gtk.scm
@@ -1599,8 +1599,37 @@
(("rust-shell-words" ,rust-shell-words-0.1)
("rust-tempfile" ,rust-tempfile-3))))))
+(define-public rust-gobject-sys-0.18
+ (package
+ (name "rust-gobject-sys")
+ (version "0.18.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "gobject-sys" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0i6fhp3m6vs3wkzyc22rk2cqj68qvgddxmpaai34l72da5xi4l08"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:tests? #f ; `G_TYPE_FUNDAMENTAL_MAX` constant mismatch with gcc
+ #:cargo-inputs
+ (("rust-glib-sys" ,rust-glib-sys-0.18)
+ ("rust-libc" ,rust-libc-0.2)
+ ("rust-system-deps" ,rust-system-deps-6))
+ #:cargo-development-inputs
+ (("rust-shell-words" ,rust-shell-words-1)
+ ("rust-tempfile" ,rust-tempfile-3))))
+ (native-inputs (list pkg-config))
+ (inputs (list glib))
+ (home-page "https://gtk-rs.org/")
+ (synopsis "FFI bindings to libgobject-2.0")
+ (description "This package provides FFI bindings to libgobject-2.0.")
+ (license license:expat)))
+
(define-public rust-gobject-sys-0.17
(package
+ (inherit rust-gobject-sys-0.18)
(name "rust-gobject-sys")
(version "0.17.10")
(source (origin
@@ -1610,7 +1639,6 @@
(sha256
(base32
"0ql0pcab6dxjapiglxcjaavbbh1sznyc2wj5q273b9j0fwqw6d6d"))))
- (build-system cargo-build-system)
(arguments
`(;; XXX: Tests are sensitive to the version of glib, even though
;; the library supports a wide range. Skip for now.
@@ -1621,15 +1649,7 @@
("rust-system-deps" ,rust-system-deps-6))
#:cargo-development-inputs
(("rust-shell-words" ,rust-shell-words-1)
- ("rust-tempfile" ,rust-tempfile-3))))
- (native-inputs
- (list pkg-config))
- (inputs
- (list glib))
- (home-page "https://gtk-rs.org/")
- (synopsis "FFI bindings to libgobject-2.0")
- (description "This package provides FFI bindings to libgobject-2.0.")
- (license license:expat)))
+ ("rust-tempfile" ,rust-tempfile-3))))))
(define-public rust-gobject-sys-0.15
(package