summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-01-01 19:03:42 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-01-02 00:43:07 +0100
commit47a67d34b2b5f01e7092442cb318c61d1876dc25 (patch)
tree9d06b6441e5ba9d805ed43df83a1a6bf907a87dd /gnu/packages
parent8855e3017c2dc3c7268ab08015a4aa631b7b6864 (diff)
gnu: emacs-haskell-mode: Update to 17.5.
* gnu/packages/emacs-xyz.scm (emacs-haskell-mode): Update to 17.5. * gnu/packages/patches/emacs-haskell-mode-no-redefine-builtin.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Apply file deletion. Change-Id: Ic7d11737af87995610ecf2c3178320901991423d
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm6
-rw-r--r--gnu/packages/patches/emacs-haskell-mode-no-redefine-builtin.patch75
2 files changed, 2 insertions, 79 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a7828773dd..848eaa7ecb 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2403,7 +2403,7 @@ replacement.")
(define-public emacs-haskell-mode
(package
(name "emacs-haskell-mode")
- (version "17.4")
+ (version "17.5")
(source
(origin
(method git-fetch)
@@ -2412,9 +2412,7 @@ replacement.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "03j94fgw1bljbjqmikbn9mnrfifxf7g9zrb727zmnnrjwyi0wd4n"))
- (patches
- (search-patches "emacs-haskell-mode-no-redefine-builtin.patch"))))
+ (base32 "0ndi986rxq9gz61ss2vazadn7rn0niv1gnpk9nfq9sw3m336glsf"))))
(propagated-inputs
(list emacs-dash))
(native-inputs
diff --git a/gnu/packages/patches/emacs-haskell-mode-no-redefine-builtin.patch b/gnu/packages/patches/emacs-haskell-mode-no-redefine-builtin.patch
deleted file mode 100644
index 65ace2ee5e..0000000000
--- a/gnu/packages/patches/emacs-haskell-mode-no-redefine-builtin.patch
+++ /dev/null
@@ -1,75 +0,0 @@
-From faa95a784d2c74c72e70367a5d531df6dd61aeab Mon Sep 17 00:00:00 2001
-From: Steve Purcell <steve@sanityinc.com>
-Date: Sun, 6 Aug 2023 16:41:48 +0200
-Subject: [PATCH] Don't redefine built-in function
-
-Fixes #1817
----
- tests/haskell-indent-tests.el | 14 ++++++++------
- tests/haskell-indentation-tests.el | 14 ++++++++------
- 2 files changed, 16 insertions(+), 12 deletions(-)
-
-diff --git a/tests/haskell-indent-tests.el b/tests/haskell-indent-tests.el
-index 7196405b8..9a3de4ad3 100644
---- a/tests/haskell-indent-tests.el
-+++ b/tests/haskell-indent-tests.el
-@@ -40,11 +40,13 @@
- ;; (haskell-indent-put-region-in-literate (point-min) (point-max) -1)
- ;; (buffer-substring-no-properties (point-min) (point-max))))))
-
--(defsubst string-trim-left (string)
-- "Remove leading whitespace from STRING."
-- (if (string-match "\\`[ \t\n\r]+" string)
-- (replace-match "" t t string)
-- string))
-+(if (fboundp 'string-trim-left)
-+ (defalias 'haskell--string-trim-left 'string-trim-left)
-+ (defun haskell--string-trim-left (string &optional regexp)
-+ "Remove leading whitespace from STRING."
-+ (if (string-match (concat "\\`\\(?:" (or regexp "[ \t\n\r]+") "\\)") string)
-+ (substring string (match-end 0))
-+ string)))
-
- (defun haskell-indent-format-info (info)
- (if (cdr info)
-@@ -128,7 +130,7 @@ macro quotes them for you."
- :expected-result
- ,(if allow-failure :failed :passed)
- (haskell-indent-check
-- ,(string-trim-left source)
-+ ,(haskell--string-trim-left source)
- ,@(mapcar (lambda (x)
- (list 'quote x))
- test-cases))))))
-diff --git a/tests/haskell-indentation-tests.el b/tests/haskell-indentation-tests.el
-index 4889b76a7..cd783a4f4 100644
---- a/tests/haskell-indentation-tests.el
-+++ b/tests/haskell-indentation-tests.el
-@@ -33,11 +33,13 @@
-
- ;;; Code:
-
--(defsubst string-trim-left (string)
-- "Remove leading whitespace from STRING."
-- (if (string-match "\\`[ \t\n\r]+" string)
-- (replace-match "" t t string)
-- string))
-+(if (fboundp 'string-trim-left)
-+ (defalias 'haskell--string-trim-left 'string-trim-left)
-+ (defun haskell--string-trim-left (string &optional regexp)
-+ "Remove leading whitespace from STRING."
-+ (if (string-match (concat "\\`\\(?:" (or regexp "[ \t\n\r]+") "\\)") string)
-+ (substring string (match-end 0))
-+ string)))
-
- (defun haskell-indentation-check (source &rest test-cases)
- "Check if `haskell-indentation-find-indentations' returns expected results.
-@@ -115,7 +117,7 @@ macro quotes them for you."
- :expected-result
- ,(if allow-failure :failed :passed)
- (haskell-indentation-check
-- ,(string-trim-left source)
-+ ,(haskell--string-trim-left source)
- ,@(mapcar (lambda (x)
- (list 'quote x))
- test-cases))))))