summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-05-10 16:57:41 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-05-10 19:27:08 +0200
commit4d673ba743c7496e4b90298037688f03f0251e65 (patch)
tree4fc4057aaa67ae04f59255adc79cd2d5ab6a0897 /gnu/packages
parent26e2610673cfc3a50d5ec7dceb6ba25db8c94b07 (diff)
gnu: Add python-types-requests.
* gnu/packages/python-xyz.scm (python-types-requests): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bedb004a4b..b5456a4472 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -30965,6 +30965,23 @@ static types.")
Python, with static types.")
(license license:asl2.0)))
+(define-public python-types-requests
+ (package
+ (name "python-types-requests")
+ (version "2.30.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "types-requests" version))
+ (sha256
+ (base32
+ "0cas3cjkhrvsz2rmqnhqiihy9j79wxi9xbih8jk0p9r48c2q3iyy"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-types-urllib3))
+ (home-page "https://github.com/python/typeshed")
+ (synopsis "Typing stubs for requests")
+ (description "This package provides typing stubs for requests.")
+ (license license:asl2.0)))
+
(define-public python-types-setuptools
(package
(name "python-types-setuptools")